summaryrefslogtreecommitdiffstats
path: root/meta-security/recipes-core/systemd/systemd_239.bbappend
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-22 18:36:32 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-22 18:36:32 -0500
commit9c0f950122472154f3a87cb231b832a6b5d0617f (patch)
tree158fca8a449e8c64c29dc4c88ed429bd56282bc2 /meta-security/recipes-core/systemd/systemd_239.bbappend
parent7f2a76887d9cfe5cb1f27efd4f106d04097190eb (diff)
meta-security: handle systemd upgrade
Rename systemd bbappend to work with newer 243.2 version in oe-core. A wildcard is now used to reduce the need to rename the bbappend on future upgrades, as the additions it makes have not changed recently. Bug-AGL: SPEC-2932 Change-Id: Ie6413710e861b8dbf082bcae3d7592f1009927d5 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-security/recipes-core/systemd/systemd_239.bbappend')
-rw-r--r--meta-security/recipes-core/systemd/systemd_239.bbappend40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-security/recipes-core/systemd/systemd_239.bbappend b/meta-security/recipes-core/systemd/systemd_239.bbappend
deleted file mode 100644
index 789c05f83..000000000
--- a/meta-security/recipes-core/systemd/systemd_239.bbappend
+++ /dev/null
@@ -1,40 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-# Ensures systemd runs with label "System"
-EXTRA_OEMESON_append_with-lsm-smack = " -Dsmack-run-label=System"
-
-##################################################################################
-# Maintaining trivial, non-upstreamable configuration changes as patches
-# is tedious. But in same cases (like early mounting of special directories)
-# the configuration has to be in code. We make these changes here directly.
-##################################################################################
-do_patch[prefuncs] += "patch_systemd"
-do_patch[vardeps] += "patch_systemd"
-patch_systemd() {
- # Handling of /run and /sys/fs/cgroup. Make /run a transmuting directory to
- # enable systemd communications with services in the User domain.
- # Original patch by Michael Demeter <michael.demeter@intel.com>.
- #
- # We simplify the patching by touching only lines which check the result of
- # mac_smack_use(). Those are the ones which are used when Smack is active.
- #
- # smackfsroot=* on /sys/fs/cgroup may be upstreamable, but smackfstransmute=System::Run
- # is too distro specific (depends on Smack rules) and thus has to remain here.
- sed -i -e 's;\("/sys/fs/cgroup", *"[^"]*", *"[^"]*\)\(.*mac_smack_use.*\);\1,smackfsroot=*\2;' \
- -e 's;\("/run", *"[^"]*", *"[^"]*\)\(.*mac_smack_use.*\);\1,smackfstransmute=System::Run\2;' \
- ${S}/src/core/mount-setup.c
-}
-
-##################################################################################
-# What follows is temporary.
-# This is a solution to the Bug-AGL SPEC-539
-# (see https://jira.automotivelinux.org/browse/SPEC-539).
-#
-# It renames the file "touchscreen.rules" to "55-touchscreen.rules"
-# This comes with the recipe systemd_230/234 of poky (meta/recipes-core/systemd)
-# It should be removed when poky changes.
-##################################################################################
-do_install_prepend() {
- mv ${WORKDIR}/touchscreen.rules ${WORKDIR}/55-touchscreen.rules || true
-}
-