summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-Revert-cgroup-Disable-cgroup-memory-by-default.patch86
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend1
-rw-r--r--meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-samples-material-3-demo/flutter-samples-material-3-demo.service2
-rw-r--r--meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-samples-material-3-demo_aglflutter.inc11
4 files changed, 91 insertions, 9 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-Revert-cgroup-Disable-cgroup-memory-by-default.patch b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-Revert-cgroup-Disable-cgroup-memory-by-default.patch
new file mode 100644
index 000000000..3a0be628e
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-Revert-cgroup-Disable-cgroup-memory-by-default.patch
@@ -0,0 +1,86 @@
+From eec171e22de23a8bb7321da2bd405a95d4521f92 Mon Sep 17 00:00:00 2001
+From: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
+Date: Tue, 4 Feb 2025 00:55:36 +0900
+Subject: [PATCH] Revert "cgroup: Disable cgroup "memory" by default"
+
+This reverts commit 94a23e978235cd35f38075072b34152b2b667e6e.
+
+Upstream-Status: Pending
+
+---
+ kernel/cgroup/cgroup.c | 38 --------------------------------------
+ 1 file changed, 38 deletions(-)
+
+diff --git a/kernel/cgroup/cgroup.c b/kernel/cgroup/cgroup.c
+index 5165f5ccd1b4..518725b57200 100644
+--- a/kernel/cgroup/cgroup.c
++++ b/kernel/cgroup/cgroup.c
+@@ -6051,9 +6051,6 @@ int __init cgroup_init_early(void)
+ return 0;
+ }
+
+-static u16 cgroup_enable_mask __initdata;
+-static int __init cgroup_disable(char *str);
+-
+ /**
+ * cgroup_init - cgroup initialization
+ *
+@@ -6087,12 +6084,6 @@ int __init cgroup_init(void)
+
+ cgroup_unlock();
+
+- /*
+- * Apply an implicit disable, knowing that an explicit enable will
+- * prevent if from doing anything.
+- */
+- cgroup_disable("memory");
+-
+ for_each_subsys(ss, ssid) {
+ if (ss->early_init) {
+ struct cgroup_subsys_state *css =
+@@ -6733,10 +6724,6 @@ static int __init cgroup_disable(char *str)
+ strcmp(token, ss->legacy_name))
+ continue;
+
+- /* An explicit cgroup_enable overrides a disable */
+- if (cgroup_enable_mask & (1 << i))
+- continue;
+-
+ static_branch_disable(cgroup_subsys_enabled_key[i]);
+ pr_info("Disabling %s control group subsystem\n",
+ ss->name);
+@@ -6755,31 +6742,6 @@ static int __init cgroup_disable(char *str)
+ }
+ __setup("cgroup_disable=", cgroup_disable);
+
+-static int __init cgroup_enable(char *str)
+-{
+- struct cgroup_subsys *ss;
+- char *token;
+- int i;
+-
+- while ((token = strsep(&str, ",")) != NULL) {
+- if (!*token)
+- continue;
+-
+- for_each_subsys(ss, i) {
+- if (strcmp(token, ss->name) &&
+- strcmp(token, ss->legacy_name))
+- continue;
+-
+- cgroup_enable_mask |= 1 << i;
+- static_branch_enable(cgroup_subsys_enabled_key[i]);
+- pr_info("Enabling %s control group subsystem\n",
+- ss->name);
+- }
+- }
+- return 1;
+-}
+-__setup("cgroup_enable=", cgroup_enable);
+-
+ void __init __weak enable_debug_cgroup(void) { }
+
+ static int __init enable_cgroup_debug(char *str)
+--
+2.43.0
+
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
index ec3fa910b..65f760f46 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
@@ -5,6 +5,7 @@ require recipes-kernel/linux/linux-yocto-agl.inc
SRC_URI:append = " \
${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
file://0001-mconf-menuconfig.patch \
+ file://0001-Revert-cgroup-Disable-cgroup-memory-by-default.patch \
"
# Enable support for Pi foundation touchscreen
diff --git a/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-samples-material-3-demo/flutter-samples-material-3-demo.service b/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-samples-material-3-demo/flutter-samples-material-3-demo.service
index f3f4a94b1..f0b475baf 100644
--- a/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-samples-material-3-demo/flutter-samples-material-3-demo.service
+++ b/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-samples-material-3-demo/flutter-samples-material-3-demo.service
@@ -7,7 +7,7 @@ User=agl-driver
EnvironmentFile=/etc/default/flutter
EnvironmentFile=-/etc/default/flutter-samples-material-3-demo
Environment=XDG_RUNTIME_DIR=/run/user/1001/
-ExecStart=/usr/bin/flutter-auto -b /usr/share/flutter/flutter-samples-material-3-demo/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} -xdg-shell-app-id flutter-samples-material-3-demo
+ExecStart=/usr/bin/flutter-auto -b /usr/share/flutter/flutter-samples-material-3-demo/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --xdg-shell-app-id flutter-samples-material-3-demo
[Install]
WantedBy=graphical.target
diff --git a/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-samples-material-3-demo_aglflutter.inc b/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-samples-material-3-demo_aglflutter.inc
index 971756ad7..ebdf65d42 100644
--- a/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-samples-material-3-demo_aglflutter.inc
+++ b/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-samples-material-3-demo_aglflutter.inc
@@ -1,6 +1,8 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/flutter-samples-material-3-demo:"
-SRC_URI += "file://flutter-samples-material-3-demo.service"
+SRC_URI += "file://flutter-samples-material-3-demo.service \
+ file://flutter-samples-material-3-demo.toml \
+"
APP_CONFIG = "flutter-samples-material-3-demo.toml"
@@ -8,13 +10,6 @@ inherit systemd
do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
-
- # determine build type based on what flutter-engine installed.
- for runtime_mode in ${FLUTTER_RUNTIME_MODES}
- do
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} \
- ${D}${datadir}/flutter/${PUBSPEC_APPNAME}/${FLUTTER_SDK_VERSION}/${runtime_mode}/config.toml
- done
}
RDEPENDS:${PN} += "agl-flutter-env"