summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston/weston.sh7
-rw-r--r--meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston_%.bbappend14
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh7
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend14
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh7
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend14
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init.bbappend15
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/init108
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/runWeston39
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/weston.service13
-rw-r--r--meta-agl/recipes-core/packagegroups/packagegroup-agl-core-graphics.bb4
-rw-r--r--meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb2
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-init.bbappend20
-rw-r--r--meta-agl/recipes-graphics/wayland/weston/weston.service12
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_%.bbappend12
-rw-r--r--meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb2
16 files changed, 22 insertions, 268 deletions
diff --git a/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston/weston.sh b/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston/weston.sh
deleted file mode 100644
index 225a034bb..000000000
--- a/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston/weston.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-if test -z "$XDG_RUNTIME_DIR"; then
- export XDG_RUNTIME_DIR=/run/user/$UID
- mkdir --parents $XDG_RUNTIME_DIR
- chmod 0700 $XDG_RUNTIME_DIR
-fi
diff --git a/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston_%.bbappend b/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston_%.bbappend
deleted file mode 100644
index bdb6e44de..000000000
--- a/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston_%.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-SRC_URI_append = "\
- file://weston.sh \
- "
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/profile.d
- install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/profile.d/weston.sh \
- "
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh
deleted file mode 100644
index 225a034bb..000000000
--- a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-if test -z "$XDG_RUNTIME_DIR"; then
- export XDG_RUNTIME_DIR=/run/user/$UID
- mkdir --parents $XDG_RUNTIME_DIR
- chmod 0700 $XDG_RUNTIME_DIR
-fi
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
deleted file mode 100644
index f8c0a5fa3..000000000
--- a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-SRC_URI_append = "\
- file://weston.sh \
- "
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/profile.d
- install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/profile.d/weston.sh \
- "
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh
deleted file mode 100644
index 225a034bb..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-if test -z "$XDG_RUNTIME_DIR"; then
- export XDG_RUNTIME_DIR=/run/user/$UID
- mkdir --parents $XDG_RUNTIME_DIR
- chmod 0700 $XDG_RUNTIME_DIR
-fi
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
deleted file mode 100644
index f8c0a5fa3..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-SRC_URI_append = "\
- file://weston.sh \
- "
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/profile.d
- install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/profile.d/weston.sh \
- "
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init.bbappend b/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init.bbappend
deleted file mode 100644
index 041e5abe1..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-PR_append = ".arago7"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI_append = " \
- file://runWeston \
-"
-
-do_install_append() {
- install -d ${D}${bindir}
- install -m 755 ${WORKDIR}/runWeston ${D}${bindir}
- rm -rf ${D}${systemd_system_unitdir}
-}
-
-SYSTEMD_SERVICE_${PN} = ""
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/init b/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/init
deleted file mode 100644
index 336e5af81..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/init
+++ /dev/null
@@ -1,108 +0,0 @@
-#!/bin/sh
-#
-### BEGIN INIT INFO
-# Provides: weston
-# Required-Start: $local_fs $remote_fs
-# Required-Stop: $local_fs $remote_fs
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-### END INIT INFO
-
-killproc() {
- pid=`/bin/pidof $1`
- [ "$pid" != "" ] && kill $pid
-}
-
-read CMDLINE < /proc/cmdline
-for x in $CMDLINE; do
- case $x in
- weston=false)
- echo "Weston disabled"
- exit 0;
- ;;
- esac
-done
-
-case "$1" in
- start)
- . /etc/profile
-
- # Weston for some reason dies if these environment variables are set
- unset WAYLAND_DISPLAY
-
- # This is all a nasty hack
- if test -z "$XDG_RUNTIME_DIR"; then
- export XDG_RUNTIME_DIR=/run/user/root
- fi
-
- if [ ! -d "$XDG_RUNTIME_DIR" ] ; then
- mkdir --parents $XDG_RUNTIME_DIR
- chmod 0700 $XDG_RUNTIME_DIR
- fi
-
- openvt -c 4 -f runWeston
-
- # If there's no touchscreen device available, done
- if [ ! -e /dev/input/touchscreen0 ] ; then
- exit 0
- fi
-
- # If it was already calibrated, done
- if [ -f "$WS_CALUDEV_FILE" ] ; then
- exit 0
- fi
-
- # Check if SD card is mounted
- mount | grep /run/media/mmcblk0p1 | grep vfat > /dev/null 2>&1
- if [ "$?" = "0" ] ; then
- SD_MOUNTED="1"
- else
- SD_MOUNTED="0"
- fi
-
- # Check if SD card has a calibration rules file
- SD_CALUDEV_FILE=/run/media/mmcblk0p1/ws-calibrate.rules
- if [ "$SD_MOUNTED" = "1" -a -f "$SD_CALUDEV_FILE" ] ; then
- # Copy it over to udev location
- cp "$SD_CALUDEV_FILE" "$WS_CALUDEV_FILE"
- else
- # Run a calibration app and save output to udev rules
- echo "Calibrating touchscreen (first time only)"
- echo
- echo "*** To continue, please complete the touchscreen calibration"
- echo -n "*** by touching the crosshairs on the LCD screen"
- sleep 1
- CAL_VALUES=`weston-calibrator|cut -c21-`
- echo 'SUBSYSTEM=="input", ENV{WL_CALIBRATION}="'$CAL_VALUES'"' > $WS_CALUDEV_FILE
- echo "."
- # Copy it back to SD
- if [ "$SD_MOUNTED" = "1" ] ; then
- cp "$WS_CALUDEV_FILE" "$SD_CALUDEV_FILE"
- fi
- fi
-
- # Reload and re-run udev rules and restart weston
- udevadm control --reload
- udevadm trigger
- killproc weston
- sleep 2
- openvt -c 4 -f runWeston
- ;;
-
- stop)
- echo "Stopping Weston"
- killproc weston
- ;;
-
- restart)
- $0 stop
- sleep 2
- $0 start
- ;;
-
- *)
- echo "usage: $0 { start | stop | restart }"
- ;;
-esac
-
-exit 0
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/runWeston b/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/runWeston
deleted file mode 100644
index aed5d5f91..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston-init/weston-init/runWeston
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/bin/sh
-
-clear
-cat << EOF
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
- Please wait...
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-EOF
-
-weston --idle-time=0 >> /var/log/weston.log 2>&1
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/weston.service b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/weston.service
deleted file mode 100644
index cec707d56..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/weston.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=Weston reference Wayland compositor
-Conflicts=getty@tty1.service
-After=dbus.service rc.pvr.service
-
-[Service]
-ExecStart=/usr/bin/weston-launch -u root -- --backend=drm-backend.so --idle-time=4294967 --config=/etc/xdg/weston/weston.ini
-ExecStop=/usr/bin/killall -s KILL weston
-Restart=always
-Type=simple
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-graphics.bb b/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-graphics.bb
index 58e4e77f4..1cc6f457b 100644
--- a/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-graphics.bb
+++ b/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-graphics.bb
@@ -8,7 +8,3 @@ PACKAGES = "\
"
ALLOW_EMPTY_${PN} = "1"
-
-RDEPENDS_${PN} += "\
- ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "weston-init", "", d)} \
- "
diff --git a/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb b/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
index c3863cb43..fb7af0a45 100644
--- a/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
+++ b/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
@@ -9,7 +9,7 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
-RDEPENDS_${PN} += "weston weston-ini-conf weston-examples"
+RDEPENDS_${PN} += "weston weston-init weston-ini-conf weston-examples"
RDEPENDS_${PN} += "\
packagegroup-agl-image-minimal \
diff --git a/meta-agl/recipes-graphics/wayland/weston-init.bbappend b/meta-agl/recipes-graphics/wayland/weston-init.bbappend
new file mode 100644
index 000000000..9b0f434e5
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/weston-init.bbappend
@@ -0,0 +1,20 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+WESTONTTY ??= "1"
+WESTONUSER ??= "root"
+WESTONARGS ?= "--idle-time=4294967"
+WESTONLAUNCHARGS ??= "--tty /dev/tty${WESTONTTY} --user ${WESTONUSER}"
+
+do_install_append() {
+ sed -e 's,launcher="weston-launch.*--",launcher="weston-launch ${WESTONLAUNCHARGS} --",g' \
+ -e 's,exec openvt $openvt_args --,exec ,g' \
+ -i ${D}${bindir}/weston-start
+
+ sed -e 's,User=root,User=${WESTONUSER},g' \
+ -e 's,$OPTARGS,${WESTONARGS} $OPTARGS,g' \
+ -i ${D}${systemd_system_unitdir}/weston.service
+
+ sed -i "/\[Unit\]/aConflicts=getty@tty${WESTONTTY}.service" \
+ ${D}${systemd_system_unitdir}/weston.service
+}
+
diff --git a/meta-agl/recipes-graphics/wayland/weston/weston.service b/meta-agl/recipes-graphics/wayland/weston/weston.service
deleted file mode 100644
index afd8a7db8..000000000
--- a/meta-agl/recipes-graphics/wayland/weston/weston.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Weston reference Wayland compositor
-Conflicts=getty@tty1.service
-After=dbus.service
-
-[Service]
-ExecStart=/usr/bin/weston-launch --tty /dev/tty1 --user root -- --idle-time=4294967
-ExecStop=/usr/bin/killall -s KILL weston
-Type=simple
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-agl/recipes-graphics/wayland/weston_%.bbappend b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
index 217c4fc0b..dc984c1d1 100644
--- a/meta-agl/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
@@ -2,17 +2,5 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://0001-compositor-drm.c-Launch-without-input-devices.patch \
- file://weston.service \
"
-inherit systemd
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "weston.service"
-
-do_install_append() {
- # Install systemd unit files
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
- fi
-}
diff --git a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb
index 5021caa3a..c474b9fc5 100644
--- a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb
+++ b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb
@@ -12,6 +12,6 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
- weston weston-ini-conf weston-examples \
+ weston weston-init weston-ini-conf weston-examples \
wayland-ivi-extension \
"