summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb9
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc1
2 files changed, 9 insertions, 1 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
index 87df04e58..0030e4a14 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
@@ -12,7 +12,7 @@ DEPENDS = "wayland wayland-protocols wayland-native weston \
${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "68d184f9d541a475e15727d71f49b6df6799a054"
+SRCREV = "bd4c81d5f90d466df8019d19dca4856aa7a5fa80"
PV = "0.0.10+git${SRCPV}"
S = "${WORKDIR}/git"
@@ -28,5 +28,12 @@ FILES_${PN} = " \
${bindir}/agl-screenshooter \
${datadir}/${PN}/protocols/agl-shell.xml \
${datadir}/${PN}/protocols/agl-shell-desktop.xml \
+ ${libdir}/agl-compositor/libexec_compositor.so.0 \
+ ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
"
+
RDEPENDS_${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
+
+FILES_${PN}-dev += " \
+ ${libdir}/agl-compositor/libexec_compositor.so \
+"
diff --git a/meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc b/meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc
index 3c9bd4d43..d29d09f7f 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc
+++ b/meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc
@@ -6,6 +6,7 @@ SRC_URI_append = "\
# Workaround for incorrect upstream definition
PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
+PACKAGECONFIG[headless] = "-Dbackend-headless=true"
PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
PACKAGECONFIG_append = "${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', ' remoting', '', d)}"