summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend11
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/files/main.conf2
2 files changed, 12 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
index e41cbe954..57406fa0a 100644
--- a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
@@ -1,3 +1,12 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://0001-disable-when-booting-over-nfs.patch"
+SRC_URI += "file://0001-disable-when-booting-over-nfs.patch \
+ file://main.conf \
+"
+
+FILES_${PN} += "${sysconfdir}/connman/main.conf"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/connman
+ install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman
+}
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf b/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf
new file mode 100644
index 000000000..0bfbe09dc
--- /dev/null
+++ b/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf
@@ -0,0 +1,2 @@
+[General]
+FallbackTimeservers=pool.ntp.org