summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch26
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend1
2 files changed, 0 insertions, 27 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch
deleted file mode 100644
index 44bae715e..000000000
--- a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 0d85faf308285c6a1f77f01660a2ce0541bfa5b4 Mon Sep 17 00:00:00 2001
-From: Matt Ranostay <matt.ranostay@konsulko.com>
-Date: Wed, 12 Jun 2019 17:04:00 -0700
-Subject: [PATCH] obex: report notification status on incoming message
-
-To match doc/obex.txt on incoming message notification the respective
-Status field should be set.
----
- obexd/client/map.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/obexd/client/map.c b/obexd/client/map.c
-index 550c5afb4..23be2d6b2 100644
---- a/obexd/client/map.c
-+++ b/obexd/client/map.c
-@@ -1914,6 +1914,7 @@ static void map_handle_notification(struct map_event *event, void *user_data)
- switch (event->type) {
- case MAP_ET_NEW_MESSAGE:
- map_handle_new_message(map, event);
-+ map_handle_status_changed(map, event, "notification");
- break;
- case MAP_ET_DELIVERY_SUCCESS:
- map_handle_status_changed(map, event, "delivery-success");
---
-2.20.1
-
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
index 55459c1ac..52ae30bc5 100644
--- a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -4,7 +4,6 @@ SRC_URI_append = " \
file://tmpdir.conf \
file://obex.service \
file://bluetooth.service \
- file://0001-obex-report-notification-status-on-incoming-message.patch \
"
FILES_${PN} += "${systemd_user_unitdir}/obex.service.d/tmpdir.conf"