summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg2
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack-default-lsm.cfg6
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack.cfg8
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend6
4 files changed, 4 insertions, 18 deletions
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg
index 327c753ae..95de5181e 100644
--- a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg
@@ -1 +1,3 @@
+CONFIG_USB_HID=y
+# CONFIG_HID_PID is not set
CONFIG_HID_MULTITOUCH=y
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack-default-lsm.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack-default-lsm.cfg
deleted file mode 100644
index 5914b3fba..000000000
--- a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack-default-lsm.cfg
+++ /dev/null
@@ -1,6 +0,0 @@
-CONFIG_DEFAULT_SECURITY="smack"
-CONFIG_DEFAULT_SECURITY_SMACK=y
-# CONFIG_DEFAULT_SECURITY_SELINUX is not set
-# CONFIG_DEFAULT_SECURITY_APPARMOR is not set
-# CONFIG_DEFAULT_SECURITY_YAMA is not set
-# CONFIG_DEFAULT_SECURITY_DAC is not set \ No newline at end of file
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack.cfg
deleted file mode 100644
index 62f465a45..000000000
--- a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack.cfg
+++ /dev/null
@@ -1,8 +0,0 @@
-CONFIG_IP_NF_SECURITY=m
-CONFIG_IP6_NF_SECURITY=m
-CONFIG_EXT2_FS_SECURITY=y
-CONFIG_EXT3_FS_SECURITY=y
-CONFIG_EXT4_FS_SECURITY=y
-CONFIG_SECURITY=y
-CONFIG_SECURITY_SMACK=y
-CONFIG_TMPFS_XATTR=y
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
index e2996f95c..5dbd457df 100644
--- a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
@@ -1,5 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+DEPENDS += "kern-tools-native"
+
# Enable support for AR9271
SRC_URI_append = " file://ath9k_htc.cfg"
@@ -15,10 +17,6 @@ SRC_URI_append = " file://hid.cfg"
# Enable support for RTLSDR
SRC_URI_append = " file://rtl_sdr.cfg"
-# Set security default to SMACK
-SRC_URI_append = " file://smack.cfg"
-SRC_URI_append = " file://smack-default-lsm.cfg"
-
# returns all the elements from the src uri that are .cfg files
def find_cfgs(d):
sources=src_patches(d, True)