summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-distro/conf/distro/include/arm-default-tune.inc18
-rw-r--r--meta-agl-distro/conf/distro/poky-agl.conf (renamed from meta-agl/conf/distro/poky-agl.conf)0
-rw-r--r--meta-agl-distro/conf/layer.conf10
-rw-r--r--templates/base/bblayers.conf.sample1
4 files changed, 29 insertions, 0 deletions
diff --git a/meta-agl-distro/conf/distro/include/arm-default-tune.inc b/meta-agl-distro/conf/distro/include/arm-default-tune.inc
new file mode 100644
index 000000000..5a6f44fe5
--- /dev/null
+++ b/meta-agl-distro/conf/distro/include/arm-default-tune.inc
@@ -0,0 +1,18 @@
+def arm_tune_handler(d):
+ features = d.getVar('TUNE_FEATURES', True).split()
+ if 'armv7a' in features or 'armv7ve' in features:
+ tune = 'armv7athf'
+ if 'bigendian' in features:
+ tune += 'b'
+ if 'vfpv3' in features:
+ tune += '-vfpv3'
+ if 'vfpv3d16' in features:
+ tune += '-vfpv3d16'
+ if 'neon' in features:
+ tune += '-neon'
+ if 'vfpv4' in features:
+ tune += '-vfpv4'
+ else:
+ tune = d.getVar('DEFAULTTUNE', True)
+ return tune
+DEFAULTTUNE_agl := "${@arm_tune_handler(d)}"
diff --git a/meta-agl/conf/distro/poky-agl.conf b/meta-agl-distro/conf/distro/poky-agl.conf
index 94e4f8000..94e4f8000 100644
--- a/meta-agl/conf/distro/poky-agl.conf
+++ b/meta-agl-distro/conf/distro/poky-agl.conf
diff --git a/meta-agl-distro/conf/layer.conf b/meta-agl-distro/conf/layer.conf
new file mode 100644
index 000000000..74527516a
--- /dev/null
+++ b/meta-agl-distro/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH =. "${LAYERDIR}:"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "agl-distro"
+BBFILE_PATTERN_agl-distro = "^${LAYERDIR}/"
+BBFILE_PRIORITY_agl-distro = "8"
diff --git a/templates/base/bblayers.conf.sample b/templates/base/bblayers.conf.sample
index ebba0d7f7..12f750c70 100644
--- a/templates/base/bblayers.conf.sample
+++ b/templates/base/bblayers.conf.sample
@@ -25,6 +25,7 @@ YOCTO_LAYERS = " \
AGL_CORE_LAYERS = " \
${METADIR}/meta-agl/meta-ivi-common \
${METADIR}/meta-agl/meta-agl \
+ ${METADIR}/meta-agl/meta-agl-distro \
${METADIR}/meta-agl/meta-agl-bsp \
"