summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-profile-core/recipes-core/qemu/qemu_2.%.bbappend1
-rw-r--r--meta-agl-profile-graphical-qt5/recipes-qt/qlibhomescreen/qlibhomescreen_git.bb13
-rw-r--r--meta-agl-profile-graphical-qt5/recipes-qt/qlibwindowmanager/qlibwindowmanager_git.bb14
-rw-r--r--meta-agl-profile-graphical/recipes-apis/agl-service-homescreen/agl-service-homescreen_git.bb14
-rw-r--r--meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bb33
-rw-r--r--meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/files/weston-ready.conf4
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/hmi-debug/files/hmi-debug8
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/hmi-debug/hmi-debug_git.bb19
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen/org.agl.statusbar.conf16
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb26
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/libwindowmanager/libwindowmanager_git.bb15
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/runxdg/runxdg_git.bb16
-rw-r--r--templates/feature/agl-egvirt/50_local.conf.inc9
-rw-r--r--templates/feature/agl-hmi-framework/50_local.conf.inc5
14 files changed, 193 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-core/qemu/qemu_2.%.bbappend b/meta-agl-profile-core/recipes-core/qemu/qemu_2.%.bbappend
new file mode 100644
index 000000000..1a6a98b7f
--- /dev/null
+++ b/meta-agl-profile-core/recipes-core/qemu/qemu_2.%.bbappend
@@ -0,0 +1 @@
+QEMU_TARGETS_class-target_aglegvirt = " aarch64 x86_64"
diff --git a/meta-agl-profile-graphical-qt5/recipes-qt/qlibhomescreen/qlibhomescreen_git.bb b/meta-agl-profile-graphical-qt5/recipes-qt/qlibhomescreen/qlibhomescreen_git.bb
new file mode 100644
index 000000000..09a262eb7
--- /dev/null
+++ b/meta-agl-profile-graphical-qt5/recipes-qt/qlibhomescreen/qlibhomescreen_git.bb
@@ -0,0 +1,13 @@
+SUMMARY = "A wrapper library of libhomescreen for Qt Application in AGL"
+SECTION = "libs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS = "qtbase libhomescreen"
+RDEPENDS_${PN} = "libhomescreen"
+
+inherit qmake5
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqthomescreen.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "b218476402bceda7eb42d41064552a7261ff3205"
+S = "${WORKDIR}/git"
diff --git a/meta-agl-profile-graphical-qt5/recipes-qt/qlibwindowmanager/qlibwindowmanager_git.bb b/meta-agl-profile-graphical-qt5/recipes-qt/qlibwindowmanager/qlibwindowmanager_git.bb
new file mode 100644
index 000000000..883ab82d3
--- /dev/null
+++ b/meta-agl-profile-graphical-qt5/recipes-qt/qlibwindowmanager/qlibwindowmanager_git.bb
@@ -0,0 +1,14 @@
+SUMMARY = "A wrapper library of libwindowmanager for Qt Application in AGL"
+SECTION = "graphics"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS = "qtbase libwindowmanager"
+RDEPENDS_${PN} = "libwindowmanager"
+
+inherit qmake5
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtwindowmanager.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "3ff07151af5040842dd1e56d8312ee39cc50f533"
+S = "${WORKDIR}/git"
+PV = "1.0+git${SRCPV}"
diff --git a/meta-agl-profile-graphical/recipes-apis/agl-service-homescreen/agl-service-homescreen_git.bb b/meta-agl-profile-graphical/recipes-apis/agl-service-homescreen/agl-service-homescreen_git.bb
new file mode 100644
index 000000000..6b250f839
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-apis/agl-service-homescreen/agl-service-homescreen_git.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Homescreen binding and client library for application"
+DESCRIPTION = "agl-service-homescreen is the binding library"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen"
+SECTION = "HMI"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "dbus glib-2.0 af-binder json-c"
+
+inherit cmake aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "6c3015a7607c45313fa10792b9914864f8c25831"
+S = "${WORKDIR}/git"
diff --git a/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bb b/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bb
new file mode 100644
index 000000000..9be3550c9
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Window Manager service binding for applications"
+DESCRIPTION = "Window Manager is the service binding for controlling \
+ rendering rights. Applications request to render itself, \
+ then Window Manager checks the policy and notifies the \
+ layout to the respective applications \
+ "
+HOMEPAGE = "https://wiki.automotivelinux.org/windowmanager"
+SECTION = "graphics"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS = "af-binder json-c wayland wayland-ivi-extension"
+
+inherit cmake aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager;protocol=https;branch=${AGL_BRANCH} \
+ file://weston-ready.conf \
+"
+SRCREV = "b6644e5cffa84e40d62e38f4ee0c14e64e0faf48"
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ # Install systemd over-ride that adds a dependency on weston-ready
+ # to ensure that the windowmanager and its dependencies start after
+ # weston is actually initialized.
+ install -d ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
+ install -m 0644 ${WORKDIR}/weston-ready.conf ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
+}
+
+FILES_${PN} += "${systemd_system_unitdir}"
+
+REDEPENDS_${PN} += "weston-ready"
diff --git a/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/files/weston-ready.conf b/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/files/weston-ready.conf
new file mode 100644
index 000000000..e90eed5f8
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/files/weston-ready.conf
@@ -0,0 +1,4 @@
+[Unit]
+Requires=weston-ready.service
+After=weston-ready.service
+
diff --git a/meta-agl-profile-graphical/recipes-graphics/hmi-debug/files/hmi-debug b/meta-agl-profile-graphical/recipes-graphics/hmi-debug/files/hmi-debug
new file mode 100644
index 000000000..fee9573b7
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/hmi-debug/files/hmi-debug
@@ -0,0 +1,8 @@
+#You can select log level of HMI framework
+#1 ERROR
+#2 WARNING
+#3 NOTICE
+#4 INFO
+#5 DEBUG
+#If you want to output debug log about hmi-framework, please uncomment the following.
+#USE_HMI_DEBUG=5
diff --git a/meta-agl-profile-graphical/recipes-graphics/hmi-debug/hmi-debug_git.bb b/meta-agl-profile-graphical/recipes-graphics/hmi-debug/hmi-debug_git.bb
new file mode 100644
index 000000000..27fb60d66
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/hmi-debug/hmi-debug_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Configurations for HMI framework"
+
+SECTION = "HMI"
+LICENSE = "Apache-2.0"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = " \
+ file://hmi-debug \
+"
+
+FILES_${PN} = " \
+ ${sysconfdir}/afm/unit.env.d \
+"
+
+do_install() {
+ install -d ${D}${sysconfdir}/afm/unit.env.d
+ install -m 644 ${WORKDIR}/hmi-debug ${D}${sysconfdir}/afm/unit.env.d
+}
diff --git a/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen/org.agl.statusbar.conf b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen/org.agl.statusbar.conf
new file mode 100644
index 000000000..dc3852eee
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen/org.agl.statusbar.conf
@@ -0,0 +1,16 @@
+<!DOCTYPE busconfig PUBLIC
+"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
+"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+ <policy context="default">
+ <!-- Allow everyone to talk to main service. We'll later add an agent to
+ only share the location if user allows it. -->
+ <allow send_interface="org.agl.statusbar"/>
+ </policy>
+
+ <policy user="root">
+ <!-- Allow root to own the name on the bus -->
+ <allow own="org.agl.statusbar"/>
+ </policy>
+</busconfig>
+
diff --git a/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
new file mode 100644
index 000000000..1acd7af82
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "AGL Home Screen Library"
+DESCRIPTION = "libhomescreen"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "libs"
+
+BBCLASSEXTEND = " nativesdk"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "af-binder json-c"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
+ file://org.agl.statusbar.conf \
+ "
+SRCREV = "44290c49e08fe52d6e3ed80720473577131090f4"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ mkdir -p ${D}${sysconfdir}/dbus-1/session.d
+ install -m 0644 ${WORKDIR}/org.agl.statusbar.conf ${D}${sysconfdir}/dbus-1/session.d
+}
+
+RDEPENDS_${PN} = "agl-service-homescreen"
diff --git a/meta-agl-profile-graphical/recipes-graphics/libwindowmanager/libwindowmanager_git.bb b/meta-agl-profile-graphical/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
new file mode 100644
index 000000000..04a83dd14
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Window Manager client library for applications"
+DESCRIPTION = "Window Manager client library for application built with recipe"
+SECTION = "graphics"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS = "af-binder json-c"
+RDEPENDS_${PN} = "agl-service-windowmanager"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libwindowmanager.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "003cdfb640b595345b0d4d09471872c9295d0bc7"
+S = "${WORKDIR}/git"
+PV = "1.0+git${SRCPV}"
diff --git a/meta-agl-profile-graphical/recipes-graphics/runxdg/runxdg_git.bb b/meta-agl-profile-graphical/recipes-graphics/runxdg/runxdg_git.bb
new file mode 100644
index 000000000..d5bd568bd
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/runxdg/runxdg_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Launcher of XDG application on AGL HMI Framework (2017)"
+DESCRIPTION = "The command 'runxdg' is a launcher to execute XDG application \
+ on AGL HMI Framework which using wayland-ivi-extension"
+HOMEPAGE = "https://git.automotivelinux.org/staging/xdg-launcher"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+DEPENDS = "json-c wayland wayland-ivi-extension libhomescreen libwindowmanager"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/xdg-launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
diff --git a/templates/feature/agl-egvirt/50_local.conf.inc b/templates/feature/agl-egvirt/50_local.conf.inc
new file mode 100644
index 000000000..48590c408
--- /dev/null
+++ b/templates/feature/agl-egvirt/50_local.conf.inc
@@ -0,0 +1,9 @@
+#see meta-agl-devel/meta-egvirt/conf/include/agl_egvirt.inc
+require conf/include/agl_egvirt.inc
+
+# In order to enable the agl virtualization features (agl-egvirt),
+# each supported board needs to add in one of its configuration
+# files (see for instance meta-agl/meta-agl-bsp/conf/include)
+# the following line:
+#
+# MACHINE_FEATURES += "agl-egvirt"
diff --git a/templates/feature/agl-hmi-framework/50_local.conf.inc b/templates/feature/agl-hmi-framework/50_local.conf.inc
new file mode 100644
index 000000000..845a5270e
--- /dev/null
+++ b/templates/feature/agl-hmi-framework/50_local.conf.inc
@@ -0,0 +1,5 @@
+# In order to enable the hmi-framework features ,
+# enables the following line:
+#
+DISTRO_FEATURES_append = " agl-hmi-framework"
+PREFERRED_RPROVIDER_virtual/navigation = "navigation"