summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/conf/include
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/conf/include')
-rw-r--r--meta-agl-bsp/conf/include/agl_cubox-i.inc24
-rw-r--r--meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc4
-rw-r--r--meta-agl-bsp/conf/include/agl_jetson-agx-orin-devkit.inc20
-rw-r--r--meta-agl-bsp/conf/include/agl_qemuarm.inc2
-rw-r--r--meta-agl-bsp/conf/include/agl_qemuarm64.inc2
-rw-r--r--meta-agl-bsp/conf/include/agl_raspberrypi4.inc12
-rw-r--r--meta-agl-bsp/conf/include/agl_raspberrypi5.inc21
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar.inc7
-rw-r--r--meta-agl-bsp/conf/include/agl_rk3588.inc12
-rw-r--r--meta-agl-bsp/conf/include/agl_s4sk.inc5
10 files changed, 60 insertions, 49 deletions
diff --git a/meta-agl-bsp/conf/include/agl_cubox-i.inc b/meta-agl-bsp/conf/include/agl_cubox-i.inc
index ee5e759e4..fc0e14b5f 100644
--- a/meta-agl-bsp/conf/include/agl_cubox-i.inc
+++ b/meta-agl-bsp/conf/include/agl_cubox-i.inc
@@ -1,15 +1,21 @@
require agl_imx6-common.inc
-# Force use of the community supported LTS kernel instead of the
-# default linux-fslc
-PREFERRED_PROVIDER_virtual/kernel = "linux-fslc-lts"
+# Temporary fix for upstream breakage
+# Note that the :cubox-i override is needed because we're
+# overriding a definition done in the machine .conf.
+KERNEL_DEVICETREE:cubox-i = " \
+ nxp/imx/imx6dl-cubox-i.dtb \
+ nxp/imx/imx6q-cubox-i.dtb \
+ nxp/imx/imx6dl-hummingboard.dtb \
+ nxp/imx/imx6q-hummingboard.dtb \
+"
# Include devicetrees for SOM 1.5 and Hummingboard 2 hardware
KERNEL_DEVICETREE:append = " \
- imx6dl-hummingboard-som-v15.dtb \
- imx6q-hummingboard-som-v15.dtb \
- imx6dl-hummingboard2.dtb \
- imx6q-hummingboard2.dtb \
- imx6dl-hummingboard2-som-v15.dtb \
- imx6q-hummingboard2-som-v15.dtb \
+ nxp/imx/imx6dl-hummingboard-som-v15.dtb \
+ nxp/imx/imx6q-hummingboard-som-v15.dtb \
+ nxp/imx/imx6dl-hummingboard2.dtb \
+ nxp/imx/imx6q-hummingboard2.dtb \
+ nxp/imx/imx6dl-hummingboard2-som-v15.dtb \
+ nxp/imx/imx6q-hummingboard2-som-v15.dtb \
"
diff --git a/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc b/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc
index f058ba1a5..cb13de713 100644
--- a/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc
+++ b/meta-agl-bsp/conf/include/agl_imx6qdlsabreauto.inc
@@ -1,5 +1 @@
require agl_imx6-common.inc
-
-# Force use of the community supported LTS kernel instead of the
-# default linux-fslc
-IMX_DEFAULT_KERNEL:imx6qdlsabreauto = "linux-fslc-lts"
diff --git a/meta-agl-bsp/conf/include/agl_jetson-agx-orin-devkit.inc b/meta-agl-bsp/conf/include/agl_jetson-agx-orin-devkit.inc
new file mode 100644
index 000000000..8dc846123
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_jetson-agx-orin-devkit.inc
@@ -0,0 +1,20 @@
+# Default IMAGE FSTYPES - tegraflash for flashing and ext3 for netboot
+AGL_DEFAULT_IMAGE_FSTYPES := "tegraflash ext3.xz"
+# Default initramfs fstypes - ext3 for netboot and cpio.gz for flashing
+AGL_DEFAULT_INITRAMFS_FSTYPES := "ext3.gz cpio.gz"
+
+# NOTE: we avoid ext4 for now due to optional features introduced in newer
+# e2fsprogs and older kernels (e.g. for the tegra) not supporting these, yet.
+# Downgrade filesystem to ext3
+IMAGE_TEGRAFLASH_FS_TYPE = "ext3"
+
+# DISABLE spdx ... fails on nvidia specific package
+INHERIT:remove = "create-spdx"
+
+# enforce nvme0n1p1
+TNSPEC_BOOTDEV:forcevariable = "nvme0n1p1"
+TNSPEC_BOOTDEV_DEFAULT:forcevariable = "nvme0n1p1"
+
+# DISABLE LTTNG due to FTBS
+LTTNGMODULES:forcevariable = ""
+LTTNGTOOLS:forcevariable = "" \ No newline at end of file
diff --git a/meta-agl-bsp/conf/include/agl_qemuarm.inc b/meta-agl-bsp/conf/include/agl_qemuarm.inc
index 2449e1800..8a41757ef 100644
--- a/meta-agl-bsp/conf/include/agl_qemuarm.inc
+++ b/meta-agl-bsp/conf/include/agl_qemuarm.inc
@@ -16,5 +16,5 @@ QB_MEM:qemuarm = "-m 2048"
# Changes to make runqemu work out-of-the-box
QB_AUDIO_DRV:qemuarm := "alsa"
QB_MACHINE:qemuarm := "-machine virt-2.11 -smp 4"
-QB_OPT_APPEND:qemuarm := "-show-cursor -device VGA,vgamem_mb=64,edid=on -device qemu-xhci -device usb-tablet -device usb-kbd -object rng-random,filename=/dev/urandom,id=rng0 -device virtio-rng-pci,rng=rng0"
+QB_OPT_APPEND:qemuarm := "-device VGA,vgamem_mb=64,edid=on -device qemu-xhci -device usb-tablet -device usb-kbd"
QB_KERNEL_CMDLINE_APPEND:qemuarm := "console=ttyAMA0 verbose vmalloc=256M"
diff --git a/meta-agl-bsp/conf/include/agl_qemuarm64.inc b/meta-agl-bsp/conf/include/agl_qemuarm64.inc
index 46d3b4c39..8e292c50b 100644
--- a/meta-agl-bsp/conf/include/agl_qemuarm64.inc
+++ b/meta-agl-bsp/conf/include/agl_qemuarm64.inc
@@ -16,5 +16,5 @@ QB_MEM:qemuarm64 = "-m 2048"
# Changes to make runqemu work out-of-the-box
QB_AUDIO_DRV:qemuarm64 := "alsa"
QB_MACHINE:qemuarm64 := "-machine virt -smp 4"
-QB_OPT_APPEND:qemuarm64 := " -show-cursor -device VGA,vgamem_mb=64,edid=on -device qemu-xhci -device usb-tablet -device usb-kbd -object rng-random,filename=/dev/urandom,id=rng0 -device virtio-rng-pci,rng=rng0"
+QB_OPT_APPEND:qemuarm64 := " -device VGA,vgamem_mb=64,edid=on -device qemu-xhci -device usb-tablet -device usb-kbd"
QB_KERNEL_CMDLINE_APPEND:qemuarm64 := "console=ttyAMA0,115200n8 verbose" \ No newline at end of file
diff --git a/meta-agl-bsp/conf/include/agl_raspberrypi4.inc b/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
index 4ba7ff0f6..998ffedc8 100644
--- a/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
+++ b/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
@@ -21,17 +21,5 @@ IMAGE_INSTALL:append = " kernel-modules linux-firmware-rpidistro-bcm43430 linux-
# Psplash causes crash on first boot on RPi
IMAGE_FEATURES:remove = "splash"
-# Build updatable image. Only takes effect when sota.bbclass is inherited
-DISTRO_FEATURES:append = " sota"
-
-# Add xen build, if the xen feature activated
-DISTRO_FEATURES:append = " ${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen', '', d)}"
-
-# add xen-tools to build
-IMAGE_INSTALL:append = " ${@bb.utils.contains('AGL_XEN_WANTED', '1', 'xen-tools xen-mkimage-rpi4', '', d)}"
-
-# Add xen-raspberry binary to boot files
-IMAGE_BOOT_FILES:append = " ${@bb.utils.contains('AGL_XEN_WANTED','1', 'xen-${MACHINE}', '',d)}"
-
#DISPLAY CONFIGURATION
WESTON_DISPLAYS:raspberrypi4 = " hdmi-a-1-90 hdmi-a-2-90"
diff --git a/meta-agl-bsp/conf/include/agl_raspberrypi5.inc b/meta-agl-bsp/conf/include/agl_raspberrypi5.inc
index a0e675956..4db5bb762 100644
--- a/meta-agl-bsp/conf/include/agl_raspberrypi5.inc
+++ b/meta-agl-bsp/conf/include/agl_raspberrypi5.inc
@@ -4,8 +4,8 @@ GPU_MEM = "256"
# Add CMA to the kernel arguments for SOTA
OSTREE_KERNEL_ARGS:sota:append = " cma=256M"
-# use u-boot always (RPi5 U-boot is not ready yet)
-RPI_USE_U_BOOT = "0"
+# use u-boot always
+RPI_USE_U_BOOT = "1"
# Use UART for serial console
ENABLE_UART ?= "1"
@@ -13,22 +13,13 @@ ENABLE_UART ?= "1"
# For libomxil
#LICENSE_FLAGS_ACCEPTED = "commercial"
-IMAGE_INSTALL:append = " kernel-modules linux-firmware-rpidistro-bcm43430 linux-firmware-rpidistro-bcm43455 create-combined-dtb "
+# For linux-firmware-rpidistro
+LICENSE_FLAGS_ACCEPTED += "synaptics-killswitch"
+
+IMAGE_INSTALL:append = " kernel-modules create-combined-dtb "
# Psplash causes crash on first boot on RPi
IMAGE_FEATURES:remove = "splash"
-# Build updatable image. Only takes effect when sota.bbclass is inherited
-DISTRO_FEATURES:append = " sota"
-
-# Add xen build, if the xen feature activated
-DISTRO_FEATURES:append = " ${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen', '', d)}"
-
-# add xen-tools to build
-IMAGE_INSTALL:append = " ${@bb.utils.contains('AGL_XEN_WANTED', '1', 'xen-tools xen-mkimage-rpi4', '', d)}"
-
-# Add xen-raspberry binary to boot files
-IMAGE_BOOT_FILES:append = " ${@bb.utils.contains('AGL_XEN_WANTED','1', 'xen-${MACHINE}', '',d)}"
-
#DISPLAY CONFIGURATION
WESTON_DISPLAYS:raspberrypi5 = " hdmi-a-1-90 hdmi-a-2-90"
diff --git a/meta-agl-bsp/conf/include/agl_rcar.inc b/meta-agl-bsp/conf/include/agl_rcar.inc
index 01314f8c9..ce3b8a8f9 100644
--- a/meta-agl-bsp/conf/include/agl_rcar.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar.inc
@@ -52,10 +52,3 @@ MACHINE_EXTRA_RRECOMMENDS:append:rcar-gen3 = " \
kernel-module-vspm-if \
omx-user-module \
"
-
-# Mask out BSP layer gstreamer* 1.22.x bbappends for now, as the BSP
-# effectively is building 1.20.x plugins and packaging them as 1.22,
-# which breaks building various things. The whole directory is not
-# commented out because we still want the vspfilter plugin.
-BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx"
-BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-"
diff --git a/meta-agl-bsp/conf/include/agl_rk3588.inc b/meta-agl-bsp/conf/include/agl_rk3588.inc
new file mode 100644
index 000000000..4c3f6990f
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_rk3588.inc
@@ -0,0 +1,12 @@
+# Add for gstreamer plugins ugly
+LICENSE_FLAGS_ACCEPTED:append = " commercial"
+MACHINE_FEATURES:append:rk3588 = " multimedia"
+
+BBMASK += " \
+ meta-rockchip/recipes-multimedia/gstreamer \
+ meta-rockchip/recipes-graphics/wayland/weston_%.bbappend \
+ "
+
+MACHINE_EXTRA_RRECOMMENDS:append = " \
+ alsa-state \
+"
diff --git a/meta-agl-bsp/conf/include/agl_s4sk.inc b/meta-agl-bsp/conf/include/agl_s4sk.inc
index 8f4a91b44..91a65d8b8 100644
--- a/meta-agl-bsp/conf/include/agl_s4sk.inc
+++ b/meta-agl-bsp/conf/include/agl_s4sk.inc
@@ -7,3 +7,8 @@ WKS_FILE = "singlepart-noloader.wks"
IMAGE_INSTALL:append = " \
kernel-devicetree \
"
+
+# For systemd CAN bus configuration
+#MACHINE_FEATURES:append = " canfd"
+CANBUS_NETWORK_CONFIG = "canbus-can-fd.network"
+