summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-agl-refhw-gen3
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-agl-refhw-gen3')
-rw-r--r--meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend (renamed from meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-conf-refhw_1.0.bb)20
1 files changed, 7 insertions, 13 deletions
diff --git a/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-conf-refhw_1.0.bb b/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
index c87308eb7..3cd5aa7de 100644
--- a/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-conf-refhw_1.0.bb
+++ b/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
@@ -1,9 +1,4 @@
-SUMMARY = "AGL Reference Hardware specific gpsd configuration"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-COMPATIBLE_MACHINE = "agl-refhw-h3"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI = "file://gpsd.refhw \
file://refhw-gpsd-helper.sh \
@@ -17,6 +12,7 @@ do_compile[noexec] = "1"
do_install() {
install -D -m 0644 ${WORKDIR}/gpsd.refhw ${D}/${sysconfdir}/default/gpsd.refhw
+
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -D -m 0755 ${WORKDIR}/refhw-gpsd-helper.sh ${D}/${sbindir}/refhw-gpsd-helper.sh
install -d ${D}${sysconfdir}/systemd/system/gpsd.service.d
@@ -24,16 +20,14 @@ do_install() {
fi
}
-ALTERNATIVE_${PN} = "gpsd-defaults"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+CONFFILES:${PN} = "${sysconfdir}/default/gpsd.refhw"
+
+ALTERNATIVE:${PN} = "gpsd-defaults"
ALTERNATIVE_LINK_NAME[gpsd-defaults] = "${sysconfdir}/default/gpsd"
ALTERNATIVE_TARGET[gpsd-defaults] = "${sysconfdir}/default/gpsd.refhw"
# NOTE: Priority needs to be below default of 10 to avoid overriding the
# default configuration. The script run by the systemd drop-in
# will tweak things on boot to handle h3ulcb vs refhw.
ALTERNATIVE_PRIORITY[gpsd-defaults] = "5"
-
-CONFFILES_${PN} = "${sysconfdir}/default/gpsd.refhw"
-
-# NOTE: Explicitly not defining RPROVIDES of "virtual/gpsd-conf" to
-# avoid conflicting with the default configuration and potentially
-# changing behavior on m3ulcb/h3ulcb.