summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-core/recipes-graphics/mesa
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-core/recipes-graphics/mesa')
-rw-r--r--meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_%.bbappend3
-rw-r--r--meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_agl.inc7
2 files changed, 10 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_%.bbappend b/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_%.bbappend
new file mode 100644
index 000000000..fb797a436
--- /dev/null
+++ b/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+require ${@bb.utils.contains('AGL_FEATURES', 'aglcore', '${BPN}_agl.inc', '', d)}
diff --git a/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_agl.inc b/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_agl.inc
new file mode 100644
index 000000000..e74761317
--- /dev/null
+++ b/meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_agl.inc
@@ -0,0 +1,7 @@
+# The gallium-llvm is recommended as software 3D graphics renderer
+GALLIUM_LLVM = "gallium-llvm"
+PACKAGECONFIG:append:qemux86 = " gallium ${GALLIUM_LLVM}"
+PACKAGECONFIG:append:qemux86-64 = " gallium ${GALLIUM_LLVM}"
+PACKAGECONFIG:append:intel-corei7-64 = " gallium ${GALLIUM_LLVM}"
+
+DRIDRIVERS:append:intel-corei7-64 = ",i965"