summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-freescale-layer/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-freescale-layer/recipes-graphics')
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/files/0001-kmsro-add-imx-dcss.patch34
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/mesa_%.bbappend10
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_11.0.3.imx.bbappend2
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend10
4 files changed, 2 insertions, 54 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/files/0001-kmsro-add-imx-dcss.patch b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/files/0001-kmsro-add-imx-dcss.patch
deleted file mode 100644
index 7f7ab9124..000000000
--- a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/files/0001-kmsro-add-imx-dcss.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Add i.MX8MQ DCSS kmsro support
-
-Add required dummy entry for NXP's i.MX8MQ DCSS display controller DRM
-driver to the kmsro configuration so that the loader will not think it
-is a GPU.
-
-Upstream-Status: pending
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
----
-
-diff --git a/src/gallium/targets/dri/meson.build b/src/gallium/targets/dri/meson.build
-index ae25a21..17379c7 100644
---- a/src/gallium/targets/dri/meson.build
-+++ b/src/gallium/targets/dri/meson.build
-@@ -72,6 +72,7 @@ foreach d : [[with_gallium_kmsro, [
- 'hx8357d_dri.so',
- 'ili9225_dri.so',
- 'ili9341_dri.so',
-+ 'imx-dcss_dri.so',
- 'imx-drm_dri.so',
- 'ingenic-drm_dri.so',
- 'mcde_dri.so',
-diff --git a/src/gallium/targets/dri/target.c b/src/gallium/targets/dri/target.c
-index f71f690..41c5c75 100644
---- a/src/gallium/targets/dri/target.c
-+++ b/src/gallium/targets/dri/target.c
-@@ -97,6 +97,7 @@ DEFINE_LOADER_DRM_ENTRYPOINT(exynos)
- DEFINE_LOADER_DRM_ENTRYPOINT(hx8357d)
- DEFINE_LOADER_DRM_ENTRYPOINT(ili9225)
- DEFINE_LOADER_DRM_ENTRYPOINT(ili9341)
-+DEFINE_LOADER_DRM_ENTRYPOINT(imx_dcss)
- DEFINE_LOADER_DRM_ENTRYPOINT(imx_drm)
- DEFINE_LOADER_DRM_ENTRYPOINT(ingenic_drm)
- DEFINE_LOADER_DRM_ENTRYPOINT(mcde)
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/mesa_%.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/mesa_%.bbappend
deleted file mode 100644
index e7633f215..000000000
--- a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/mesa_%.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-
-SRC_URI += "file://0001-kmsro-add-imx-dcss.patch"
-
-# These over-rides should use "use-mainline-bsp" instead when that
-# becomes more workable for i.MX8 in upstream meta-freescale.
-
-USE_OSMESA_ONLY:etnaviv = "no"
-
-PACKAGECONFIG:append:etnaviv = " gallium etnaviv kmsro"
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_11.0.3.imx.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_11.0.3.imx.bbappend
new file mode 100644
index 000000000..ca162e28f
--- /dev/null
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_11.0.3.imx.bbappend
@@ -0,0 +1,2 @@
+# Use provided hook to disable removal of wayland from PACKAGECONFIG
+PACKAGECONFIG_IMX_REMOVALS = "x11"
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend
deleted file mode 100644
index 270d8e8f5..000000000
--- a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
-# Work around PACKAGECONFIG:remove of "x11 wayland" added to the recipe
-# in meta-freescale commit 5a5c5dd. This can be removed once the issue
-# has been resolved by a revert of that breakage upstream.
-# What is done below is effectively a disabling of the "wayland"
-# PACKAGECONFIG option and then open coding what its effects would
-# normally be, since the _remove prevents specifying it in the usual way.
-PACKAGECONFIG[wayland] = ""
-DEPENDS:append = " virtual/egl virtual/libgles2"
-PACKAGECONFIG_CONFARGS:append = " -Dbackend-wayland=true"
-