summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.19%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.19%.bbappend')
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.19%.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.19%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.19%.bbappend
new file mode 100644
index 000000000..c49b8ecb0
--- /dev/null
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.19%.bbappend
@@ -0,0 +1,20 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# adding most supported USB Bluetooth, Wifi, and Ethernet devices
+SRC_URI_append = " file://usb-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
+
+# adding support for other graphic cards to work on more PC HW
+SRC_URI_append = " file://extra-graphic-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
+
+# adding internal network in kernel for network boot
+SRC_URI_append = " file://net-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/net-devices.cfg"
+
+# Ensure we have a startup.nsh file
+SRC_URI_append = " file://startup.nsh"
+
+do_deploy_append() {
+ install -m 0755 ${WORKDIR}/startup.nsh ${DEPLOYDIR}/
+}