summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-qcom')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/ath9k_htc.cfg4
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/fanotify.cfg3
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/hid.cfg1
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/rtl_sdr.cfg4
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/uinput.cfg3
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt%.bb15
6 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/ath9k_htc.cfg b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/ath9k_htc.cfg
new file mode 100644
index 000000000..6f7d49880
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/ath9k_htc.cfg
@@ -0,0 +1,4 @@
+CONFIG_CFG80211=m
+CONFIG_MAC80211=m
+CONFIG_ATH_CARDS=m
+CONFIG_ATH9K_HTC=m
diff --git a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/fanotify.cfg b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/fanotify.cfg
new file mode 100644
index 000000000..de5dd8d31
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/fanotify.cfg
@@ -0,0 +1,3 @@
+# Enable the fanotify API (notification/interception of FS events)
+CONFIG_FANOTIFY=y
+CONFIG_FANOTIFY_ACCESS_PERMISSIONS=y
diff --git a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/hid.cfg b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/hid.cfg
new file mode 100644
index 000000000..327c753ae
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/hid.cfg
@@ -0,0 +1 @@
+CONFIG_HID_MULTITOUCH=y
diff --git a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/rtl_sdr.cfg b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/rtl_sdr.cfg
new file mode 100644
index 000000000..d4574700a
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/rtl_sdr.cfg
@@ -0,0 +1,4 @@
+CONFIG_MEDIA_USB_SUPPORT=y
+CONFIG_MEDIA_DIGITAL_TV_SUPPORT=y
+CONFIG_DVB_USB_V2=m
+CONFIG_DVB_USB_RTL28XXU=m
diff --git a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/uinput.cfg b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/uinput.cfg
new file mode 100644
index 000000000..7996ef1dd
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/uinput.cfg
@@ -0,0 +1,3 @@
+# Enable the User-level Input driver (required by "wayland-fits")
+CONFIG_INPUT_MISC=y
+CONFIG_INPUT_UINPUT=m
diff --git a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt%.bb b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt%.bb
new file mode 100644
index 000000000..c6aee5889
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt%.bb
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# Extra configuration options
+SRC_URI += "file://fanotify.cfg \
+ file://uinput.cfg \
+ file://hid.cfg "
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/fanotify.cfg ${WORKDIR}/uinput.cfg ${WORKDIR}/hid.cfg"
+
+# Enable support for TP-Link TL-W722N USB Wifi adapter
+SRC_URI += " file://ath9k_htc.cfg "
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/ath9k_htc.cfg"
+
+# Enable support for RTLSDR
+SRC_URI += " file://rtl_sdr.cfg "
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/rtl_sdr.cfg"