summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 248623699..233132911 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -4,10 +4,17 @@ TOTAL_BOARD_MEM = "3072"
do_deploy:append:raspberrypi4() {
# ENABLE CAN
if [ "${ENABLE_CAN}" = "1" ]; then
- echo "# Enable CAN" >>${DEPLOYDIR}/bootfiles/config.txt
+ echo "# Enable CAN" >> ${DEPLOYDIR}/bootfiles/config.txt
echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bootfiles/config.txt
fi
+ # ENABLE DUAL CANFD
+ if [ "${ENABLE_DUAL_CAN_FD}" = "1" ]; then
+ echo "# Enable CANFD" >> ${DEPLOYDIR}/bootfiles/config.txt
+ echo "dtoverlay=mcp251xfd-can0,oscillator=16000000,interrupt=25" >> ${DEPLOYDIR}/bootfiles/config.txt
+ echo "dtoverlay=mcp251xfd-can1,oscillator=16000000,interrupt=24" >> ${DEPLOYDIR}/bootfiles/config.txt
+ fi
+
# Handle setup with armstub file
if [ -n "${ARMSTUB}" ]; then
echo "\n# ARM stub configuration" >> ${DEPLOYDIR}/bootfiles/config.txt