summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-examples_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-examples_git.bb')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-examples_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-examples_git.bb b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-examples_git.bb
index 440fe8fdd..7ff677c80 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-examples_git.bb
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-examples_git.bb
@@ -1,6 +1,6 @@
SUMMARY = "OP-TEE examples"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=cd95ab417e23b94f381dafc453d70c30"
@@ -13,7 +13,7 @@ PV = "3.6.0+git${SRCPV}"
SRCREV = "292da2fd8db0176e0e96989268c63ef9ab910a6c"
SRC_URI = " \
- git://github.com/linaro-swg/optee_examples;branch=master;name=master \
+ git://github.com/linaro-swg/optee_examples;branch=master;name=master;protocol=https \
file://0001-secure_storage-ta-Add-a-missing-include-file.patch \
"
@@ -26,7 +26,7 @@ CFLAGS += "-Wno-extra -Wno-error=format"
TARGET_CFLAGS += "-Wno-extra -Wno-error=format"
TARGET_CC_ARCH += "${LDFLAGS}"
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
TA_DEV_KIT_DIR = "${STAGING_DIR_TARGET}/usr/share/optee/export-ta_arm64"
@@ -58,4 +58,4 @@ do_install () {
cp ${S}/hello_world/ta/include/* ${D}${includedir}
}
-FILES_${PN} += "${nonarch_base_libdir}/optee_armtz/"
+FILES:${PN} += "${nonarch_base_libdir}/optee_armtz/"