summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bbappend')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bbappend
index 6f30fa18e..f6271908f 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bbappend
@@ -4,6 +4,13 @@ SRC_URI_append = " \
file://0001-fixup-build-with-gcc7.patch \
"
+# Config names have changed in mainline u-boot since 2015.04,
+# here we want to use the old ones.
+UBOOT_MACHINE = "${BOARD_NAME}_defconfig"
+
+# Also override the override
+UBOOT_MACHINE_sota = "${BOARD_NAME}_defconfig"
+
do_deploy_prepend() {
ln -sf ${B}/${UBOOT_SREC} ${S}/${UBOOT_SREC}
}