summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend')
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
index 386112024..8d0c0ad06 100644
--- a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -1 +1,19 @@
require linux-agl.inc
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
+
+# Extra configuration options for the QEMU kernel
+SRC_URI += "file://hciattach.cfg \
+ file://virtio.cfg \
+ "
+
+# Enable some things on qemuarm64 so MOST drivers will build and load.
+SRC_URI_append_qemuarm64 = " file://most_deps.cfg"
+
+# Configuration for using the virt machine (and not versatilepb)
+SRC_URI_append_qemuarm = " file://qemuarm.cfg"
+
+# Build a generic v7 kernel instead of the arm926j one that upstream
+# qemuarm defaults to.
+KBUILD_DEFCONFIG_qemuarm = "multi_v7_defconfig"
+KCONFIG_MODE = "--alldefconfig"