summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/conf/include/agl_imx8mq-evk-viv.inc8
-rw-r--r--meta-agl-bsp/conf/include/agl_rk3588.inc2
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_12.0.3.imx.bbappend2
-rw-r--r--meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive/uEnv-visionfive2.txt22
-rw-r--r--meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive_%.bbappend1
-rw-r--r--meta-agl-bsp/riscv-layer/recipes-graphics/wayland/agl-compositor-init.bbappend7
-rw-r--r--meta-agl-bsp/riscv-layer/recipes-graphics/wayland/agl-compositor-init/agl-compositor-visionfive2.conf2
7 files changed, 33 insertions, 11 deletions
diff --git a/meta-agl-bsp/conf/include/agl_imx8mq-evk-viv.inc b/meta-agl-bsp/conf/include/agl_imx8mq-evk-viv.inc
deleted file mode 100644
index 3988fcd6f..000000000
--- a/meta-agl-bsp/conf/include/agl_imx8mq-evk-viv.inc
+++ /dev/null
@@ -1,8 +0,0 @@
-require agl_imx8mq-evk-common.inc
-
-IMX_DEFAULT_BSP = "nxp"
-
-# NOTE:
-# There is some potential benefit to using the community supported
-# linux-fslc-imx hybrid kernel here, but keeping the configuration
-# close to upstream to ease maintenance seems worthwhile.
diff --git a/meta-agl-bsp/conf/include/agl_rk3588.inc b/meta-agl-bsp/conf/include/agl_rk3588.inc
index fdd8c9a28..9d7f85090 100644
--- a/meta-agl-bsp/conf/include/agl_rk3588.inc
+++ b/meta-agl-bsp/conf/include/agl_rk3588.inc
@@ -3,7 +3,7 @@ LICENSE_FLAGS_ACCEPTED:append = " commercial"
MACHINE_FEATURES:append:rk3588 = " multimedia"
BBMASK += " \
- meta-rockchip/recipes-multimedia/gstreamer/ \
+ meta-rockchip/recipes-multimedia/gstreamer/gstreamer1.0-plugins* \
meta-rockchip/recipes-graphics/wayland/weston_%.bbappend \
"
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_12.0.3.imx.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_12.0.3.imx.bbappend
deleted file mode 100644
index ca162e28f..000000000
--- a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_12.0.3.imx.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-# Use provided hook to disable removal of wayland from PACKAGECONFIG
-PACKAGECONFIG_IMX_REMOVALS = "x11"
diff --git a/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive/uEnv-visionfive2.txt b/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive/uEnv-visionfive2.txt
new file mode 100644
index 000000000..dac31bf6b
--- /dev/null
+++ b/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive/uEnv-visionfive2.txt
@@ -0,0 +1,22 @@
+# This is the sample jh7110_uEnv.txt file for starfive visionfive U-boot
+# The current convention (SUBJECT TO CHANGE) is that this file
+# will be loaded from the third partition on the
+# MMC card.
+#devnum=1
+partnum=3
+
+# The FIT file to boot from
+fitfile=fitImage
+
+# for debugging boot
+bootargs_ext=if test ${devnum} = 0; then setenv bootargs "console=ttyS0,115200 rootwait root=/dev/mmcblk0p4"; else setenv bootargs "console=ttyS0,115200 rootwait root=/dev/mmcblk1p4"; fi;
+
+# for addr info
+fileaddr=0xa0000000
+fdtaddr=0x46000000
+# boot Linux flat or compressed 'Image' stored at 'kernel_addr_r'
+kernel_addr_r=0x40200000
+
+bootwait=setenv _delay ${bootdelay}; echo ${_delay}; while test ${_delay} > 0; do sleep 1; setexpr _delay ${_delay} - 1; echo ${_delay}; done
+
+boot2=run bootargs_ext; mmc dev ${devnum}; fatload mmc ${devnum}:${partnum} ${fileaddr} ${fitfile}; bootm ${fileaddr} \ No newline at end of file
diff --git a/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive_%.bbappend b/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive_%.bbappend
new file mode 100644
index 000000000..8dead1283
--- /dev/null
+++ b/meta-agl-bsp/riscv-layer/recipes-bsp/u-boot/u-boot-starfive_%.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-starfive:"
diff --git a/meta-agl-bsp/riscv-layer/recipes-graphics/wayland/agl-compositor-init.bbappend b/meta-agl-bsp/riscv-layer/recipes-graphics/wayland/agl-compositor-init.bbappend
new file mode 100644
index 000000000..4cdb74a5e
--- /dev/null
+++ b/meta-agl-bsp/riscv-layer/recipes-graphics/wayland/agl-compositor-init.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI:append:jh7110 = " file://agl-compositor-visionfive2.conf "
+
+do_install:append:jh7110() {
+ install -m644 ${WORKDIR}/agl-compositor-visionfive2.conf ${D}/${systemd_system_unitdir}/agl-compositor.service.d/agl-compositor-visionfive2.conf
+}
diff --git a/meta-agl-bsp/riscv-layer/recipes-graphics/wayland/agl-compositor-init/agl-compositor-visionfive2.conf b/meta-agl-bsp/riscv-layer/recipes-graphics/wayland/agl-compositor-init/agl-compositor-visionfive2.conf
new file mode 100644
index 000000000..e62c13a89
--- /dev/null
+++ b/meta-agl-bsp/riscv-layer/recipes-graphics/wayland/agl-compositor-init/agl-compositor-visionfive2.conf
@@ -0,0 +1,2 @@
+[Service]
+Environment=WESTON_FORCE_RENDERER=1