summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/conf/include/agl_dra7xx-evm.inc42
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/alsa-state/alsa-state.bbappend1
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/alsa-state/alsa-state/asound.state1347
-rwxr-xr-xmeta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/uEnv.txt1
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend16
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/files/dcan2_pinmux_enable.patch39
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend10
-rw-r--r--meta-agl-bsp/meta-ti/recipes-multimedia/pulseaudio/pulseaudio/dra7xx-evm-set-default-sink-source.patch15
-rw-r--r--meta-agl-bsp/meta-ti/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend7
9 files changed, 0 insertions, 1478 deletions
diff --git a/meta-agl-bsp/conf/include/agl_dra7xx-evm.inc b/meta-agl-bsp/conf/include/agl_dra7xx-evm.inc
deleted file mode 100644
index ccc8feb9a..000000000
--- a/meta-agl-bsp/conf/include/agl_dra7xx-evm.inc
+++ /dev/null
@@ -1,42 +0,0 @@
-
-#-------------------------------------------------
-## Graphics section ##
-#-------------------------------------------------
-PACKAGES_GFX_${MACHINE} = "ti-sgx-ddk-km"
-
-# Enable Gfx Pkgs
-MACHINE_FEATURES_append = " sgx"
-MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
-
-DEPENDS_remove = "virtual/libgl"
-
-# Preferred providers
-PREFERRED_PROVIDER_virtual/libgles1 = ""
-PREFERRED_PROVIDER_virtual/libgles2 = "ti-sgx-ddk-um"
-PREFERRED_PROVIDER_virtual/egl = "ti-sgx-ddk-um"
-PREFERRED_PROVIDER_virtual/libgbm = "ti-sgx-ddk-um"
-PREFERRED_PROVIDER_virtual/mesa = "mesa-gl"
-
-#-------------------------------------------------
-## Multimedia section ##
-#-------------------------------------------------
-
-PACKAGES_MULTIMEDIA = " \
- ipumm-fw \
- ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-misc' , '', d)} \
-"
-
-PREFERRED_PROVIDER_virtual/kernel = "linux-ti-staging"
-PREFERRED_VERSION_virtual/kernel = "4.9"
-
-# Distribution-specific runtime components
-IMAGE_INSTALL_append = " \
- ${PACKAGES_GFX} \
- ${PACKAGES_MULTIMEDIA} \
- cmem \
-"
-
-# Include WIC support based on beaglebone
-do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot"
-WKS_FILE = "sdimage-bootpart-uuid.wks"
-IMAGE_BOOT_FILES = "MLO u-boot.img uEnv.txt"
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/alsa-state/alsa-state.bbappend b/meta-agl-bsp/meta-ti/recipes-bsp/alsa-state/alsa-state.bbappend
deleted file mode 100644
index 3b2b8beb8..000000000
--- a/meta-agl-bsp/meta-ti/recipes-bsp/alsa-state/alsa-state.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend_dra7xx-evm := "${THISDIR}/${PN}:"
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/alsa-state/alsa-state/asound.state b/meta-agl-bsp/meta-ti/recipes-bsp/alsa-state/alsa-state/asound.state
deleted file mode 100644
index fe3ce6795..000000000
--- a/meta-agl-bsp/meta-ti/recipes-bsp/alsa-state/alsa-state/asound.state
+++ /dev/null
@@ -1,1347 +0,0 @@
-state.DRA7xxEVM {
- control.1 {
- iface MIXER
- name 'Left Line Mixer Line2R Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.2 {
- iface MIXER
- name 'Right Line Mixer Line2L Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.3 {
- iface MIXER
- name 'Left HP Mixer Line2R Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.4 {
- iface MIXER
- name 'Right HP Mixer Line2L Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.5 {
- iface MIXER
- name 'Left HPCOM Mixer Line2R Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.6 {
- iface MIXER
- name 'Right HPCOM Mixer Line2L Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.7 {
- iface MIXER
- name 'Line Line2 Bypass Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.8 {
- iface MIXER
- name 'HP Line2 Bypass Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.9 {
- iface MIXER
- name 'HPCOM Line2 Bypass Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.10 {
- iface MIXER
- name 'Mono Line2 Bypass Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.11 {
- iface MIXER
- name 'Mono PGA Bypass Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.12 {
- iface MIXER
- name 'Mono DAC Playback Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.13 {
- iface MIXER
- name 'Mono Playback Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.14 {
- iface MIXER
- name 'PCM Playback Volume'
- value.0 127
- value.1 127
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 127'
- dbmin -6350
- dbmax 0
- dbvalue.0 0
- dbvalue.1 0
- }
- }
- control.15 {
- iface MIXER
- name 'Left Line Mixer PGAR Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.16 {
- iface MIXER
- name 'Left Line Mixer DACR1 Playback Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.17 {
- iface MIXER
- name 'Right Line Mixer PGAL Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.18 {
- iface MIXER
- name 'Right Line Mixer DACL1 Playback Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.19 {
- iface MIXER
- name 'Left HP Mixer PGAR Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.20 {
- iface MIXER
- name 'Left HP Mixer DACR1 Playback Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.21 {
- iface MIXER
- name 'Right HP Mixer PGAL Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.22 {
- iface MIXER
- name 'Right HP Mixer DACL1 Playback Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.23 {
- iface MIXER
- name 'Left HPCOM Mixer PGAR Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.24 {
- iface MIXER
- name 'Left HPCOM Mixer DACR1 Playback Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.25 {
- iface MIXER
- name 'Right HPCOM Mixer PGAL Bypass Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.26 {
- iface MIXER
- name 'Right HPCOM Mixer DACL1 Playback Volume'
- value 118
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- }
- }
- control.27 {
- iface MIXER
- name 'Line PGA Bypass Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.28 {
- iface MIXER
- name 'Line DAC Playback Volume'
- value.0 118
- value.1 118
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 0
- dbvalue.1 0
- }
- }
- control.29 {
- iface MIXER
- name 'HP PGA Bypass Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.30 {
- iface MIXER
- name 'HP DAC Playback Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.31 {
- iface MIXER
- name 'HPCOM PGA Bypass Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.32 {
- iface MIXER
- name 'HPCOM DAC Playback Volume'
- value.0 71
- value.1 71
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 118'
- dbmin -9999999
- dbmax 0
- dbvalue.0 -2350
- dbvalue.1 -2350
- }
- }
- control.33 {
- iface MIXER
- name 'Line Playback Switch'
- value.0 true
- value.1 true
- comment {
- access 'read write'
- type BOOLEAN
- count 2
- }
- }
- control.34 {
- iface MIXER
- name 'HP Playback Switch'
- value.0 false
- value.1 false
- comment {
- access 'read write'
- type BOOLEAN
- count 2
- }
- }
- control.35 {
- iface MIXER
- name 'HPCOM Playback Switch'
- value.0 false
- value.1 false
- comment {
- access 'read write'
- type BOOLEAN
- count 2
- }
- }
- control.36 {
- iface MIXER
- name 'AGC Switch'
- value.0 false
- value.1 false
- comment {
- access 'read write'
- type BOOLEAN
- count 2
- }
- }
- control.37 {
- iface MIXER
- name 'Left AGC Target level'
- value '-5.5dB'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 '-5.5dB'
- item.1 '-8dB'
- item.2 '-10dB'
- item.3 '-12dB'
- item.4 '-14dB'
- item.5 '-17dB'
- item.6 '-20dB'
- item.7 '-24dB'
- }
- }
- control.38 {
- iface MIXER
- name 'Right AGC Target level'
- value '-5.5dB'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 '-5.5dB'
- item.1 '-8dB'
- item.2 '-10dB'
- item.3 '-12dB'
- item.4 '-14dB'
- item.5 '-17dB'
- item.6 '-20dB'
- item.7 '-24dB'
- }
- }
- control.39 {
- iface MIXER
- name 'Left AGC Attack time'
- value '8ms'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 '8ms'
- item.1 '11ms'
- item.2 '16ms'
- item.3 '20ms'
- }
- }
- control.40 {
- iface MIXER
- name 'Right AGC Attack time'
- value '8ms'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 '8ms'
- item.1 '11ms'
- item.2 '16ms'
- item.3 '20ms'
- }
- }
- control.41 {
- iface MIXER
- name 'Left AGC Decay time'
- value '100ms'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 '100ms'
- item.1 '200ms'
- item.2 '400ms'
- item.3 '500ms'
- }
- }
- control.42 {
- iface MIXER
- name 'Right AGC Decay time'
- value '100ms'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 '100ms'
- item.1 '200ms'
- item.2 '400ms'
- item.3 '500ms'
- }
- }
- control.43 {
- iface MIXER
- name 'De-emphasis Switch'
- value.0 false
- value.1 false
- comment {
- access 'read write'
- type BOOLEAN
- count 2
- }
- }
- control.44 {
- iface MIXER
- name 'PGA Capture Volume'
- value.0 79
- value.1 79
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 119'
- dbmin 0
- dbmax 5950
- dbvalue.0 3950
- dbvalue.1 3950
- }
- }
- control.45 {
- iface MIXER
- name 'PGA Capture Switch'
- value.0 true
- value.1 true
- comment {
- access 'read write'
- type BOOLEAN
- count 2
- }
- }
- control.46 {
- iface MIXER
- name 'ADC HPF Cut-off'
- value.0 Disabled
- value.1 Disabled
- comment {
- access 'read write'
- type ENUMERATED
- count 2
- item.0 Disabled
- item.1 '0.0045xFs'
- item.2 '0.0125xFs'
- item.3 '0.025xFs'
- }
- }
- control.47 {
- iface MIXER
- name 'Output Driver Power-On time'
- value '0us'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 '0us'
- item.1 '10us'
- item.2 '100us'
- item.3 '1ms'
- item.4 '10ms'
- item.5 '50ms'
- item.6 '100ms'
- item.7 '200ms'
- item.8 '400ms'
- item.9 '800ms'
- item.10 '2s'
- item.11 '4s'
- }
- }
- control.48 {
- iface MIXER
- name 'Output Driver Ramp-up step'
- value '0ms'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 '0ms'
- item.1 '1ms'
- item.2 '2ms'
- item.3 '4ms'
- }
- }
- control.49 {
- iface MIXER
- name 'Left DAC Mux'
- value DAC_L1
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 DAC_L1
- item.1 DAC_L3
- item.2 DAC_L2
- }
- }
- control.50 {
- iface MIXER
- name 'Left HPCOM Mux'
- value 'differential of HPLOUT'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 'differential of HPLOUT'
- item.1 'constant VCM'
- item.2 single-ended
- }
- }
- control.51 {
- iface MIXER
- name 'Right DAC Mux'
- value DAC_R1
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 DAC_R1
- item.1 DAC_R3
- item.2 DAC_R2
- }
- }
- control.52 {
- iface MIXER
- name 'Right HPCOM Mux'
- value 'differential of HPROUT'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 'differential of HPROUT'
- item.1 'constant VCM'
- item.2 single-ended
- item.3 'differential of HPLCOM'
- item.4 'external feedback'
- }
- }
- control.53 {
- iface MIXER
- name 'Left Line1L Mux'
- value single-ended
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 single-ended
- item.1 differential
- }
- }
- control.54 {
- iface MIXER
- name 'Left Line1R Mux'
- value single-ended
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 single-ended
- item.1 differential
- }
- }
- control.55 {
- iface MIXER
- name 'Right Line1L Mux'
- value single-ended
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 single-ended
- item.1 differential
- }
- }
- control.56 {
- iface MIXER
- name 'Right Line1R Mux'
- value single-ended
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 single-ended
- item.1 differential
- }
- }
- control.57 {
- iface MIXER
- name 'Left PGA Mixer Line1L Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.58 {
- iface MIXER
- name 'Left PGA Mixer Line1R Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.59 {
- iface MIXER
- name 'Left PGA Mixer Line2L Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.60 {
- iface MIXER
- name 'Left PGA Mixer Mic3L Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.61 {
- iface MIXER
- name 'Left PGA Mixer Mic3R Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.62 {
- iface MIXER
- name 'Left Line2L Mux'
- value single-ended
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 single-ended
- item.1 differential
- }
- }
- control.63 {
- iface MIXER
- name 'Right PGA Mixer Line1R Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.64 {
- iface MIXER
- name 'Right PGA Mixer Line1L Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.65 {
- iface MIXER
- name 'Right PGA Mixer Line2R Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.66 {
- iface MIXER
- name 'Right PGA Mixer Mic3L Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.67 {
- iface MIXER
- name 'Right PGA Mixer Mic3R Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.68 {
- iface MIXER
- name 'Right Line2R Mux'
- value single-ended
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 single-ended
- item.1 differential
- }
- }
- control.69 {
- iface MIXER
- name 'Left Line Mixer PGAL Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.70 {
- iface MIXER
- name 'Left Line Mixer DACL1 Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.71 {
- iface MIXER
- name 'Left Line Mixer PGAR Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.72 {
- iface MIXER
- name 'Left Line Mixer DACR1 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.73 {
- iface MIXER
- name 'Left Line Mixer Line2L Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.74 {
- iface MIXER
- name 'Left Line Mixer Line2R Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.75 {
- iface MIXER
- name 'Right Line Mixer PGAL Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.76 {
- iface MIXER
- name 'Right Line Mixer DACL1 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.77 {
- iface MIXER
- name 'Right Line Mixer PGAR Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.78 {
- iface MIXER
- name 'Right Line Mixer DACR1 Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.79 {
- iface MIXER
- name 'Right Line Mixer Line2L Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.80 {
- iface MIXER
- name 'Right Line Mixer Line2R Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.81 {
- iface MIXER
- name 'Left HP Mixer PGAL Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.82 {
- iface MIXER
- name 'Left HP Mixer DACL1 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.83 {
- iface MIXER
- name 'Left HP Mixer PGAR Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.84 {
- iface MIXER
- name 'Left HP Mixer DACR1 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.85 {
- iface MIXER
- name 'Left HP Mixer Line2L Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.86 {
- iface MIXER
- name 'Left HP Mixer Line2R Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.87 {
- iface MIXER
- name 'Right HP Mixer PGAL Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.88 {
- iface MIXER
- name 'Right HP Mixer DACL1 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.89 {
- iface MIXER
- name 'Right HP Mixer PGAR Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.90 {
- iface MIXER
- name 'Right HP Mixer DACR1 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.91 {
- iface MIXER
- name 'Right HP Mixer Line2L Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.92 {
- iface MIXER
- name 'Right HP Mixer Line2R Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.93 {
- iface MIXER
- name 'Left HPCOM Mixer PGAL Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.94 {
- iface MIXER
- name 'Left HPCOM Mixer DACL1 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.95 {
- iface MIXER
- name 'Left HPCOM Mixer PGAR Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.96 {
- iface MIXER
- name 'Left HPCOM Mixer DACR1 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.97 {
- iface MIXER
- name 'Left HPCOM Mixer Line2L Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.98 {
- iface MIXER
- name 'Left HPCOM Mixer Line2R Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.99 {
- iface MIXER
- name 'Right HPCOM Mixer PGAL Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.100 {
- iface MIXER
- name 'Right HPCOM Mixer DACL1 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.101 {
- iface MIXER
- name 'Right HPCOM Mixer PGAR Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.102 {
- iface MIXER
- name 'Right HPCOM Mixer DACR1 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.103 {
- iface MIXER
- name 'Right HPCOM Mixer Line2L Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.104 {
- iface MIXER
- name 'Right HPCOM Mixer Line2R Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.105 {
- iface MIXER
- name 'Mono Mixer Line2L Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.106 {
- iface MIXER
- name 'Mono Mixer PGAL Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.107 {
- iface MIXER
- name 'Mono Mixer DACL1 Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.108 {
- iface MIXER
- name 'Mono Mixer Line2R Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.109 {
- iface MIXER
- name 'Mono Mixer PGAR Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.110 {
- iface MIXER
- name 'Mono Mixer DACR1 Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
-}
-state.H58040000encode {
- control {
- }
-}
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/uEnv.txt b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/uEnv.txt
deleted file mode 100755
index 79f3d1ff2..000000000
--- a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/uEnv.txt
+++ /dev/null
@@ -1 +0,0 @@
-fdtfile=dra7-evm-lcd-osd101t2045.dtb
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
deleted file mode 100644
index d1b9b2704..000000000
--- a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
+++ /dev/null
@@ -1,16 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-PR_append = "_agl"
-
-SRC_URI += " file://${UBOOT_ENV_BINARY}"
-
-UBOOT_ENV = "uEnv"
-
-do_deploy_append () {
- if [ "x${UBOOT_ENV}" != "x" ]
- then
- install ${WORKDIR}/${UBOOT_ENV_BINARY} ${DEPLOYDIR}/${UBOOT_ENV_IMAGE}
- ln -sf ${UBOOT_ENV_IMAGE} ${DEPLOYDIR}/${UBOOT_ENV_SYMLINK}
- fi
-}
-
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/dcan2_pinmux_enable.patch b/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/dcan2_pinmux_enable.patch
deleted file mode 100644
index 6c54c5ee1..000000000
--- a/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/dcan2_pinmux_enable.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/arch/arm/boot/dts/dra7-evm.dts b/arch/arm/boot/dts/dra7-evm.dts
-index 35424da..08fca09 100644
---- a/arch/arm/boot/dts/dra7-evm.dts
-+++ b/arch/arm/boot/dts/dra7-evm.dts
-@@ -243,6 +243,20 @@
- DRA7XX_CORE_IOPAD(0x380c, PIN_INPUT | MUX_MODE1) /* i2c2_scl.hdmi1_ddc_sda */
- >;
- };
-+ dcan2_pins_default: dcan2_pins_default {
-+ pinctrl-single,pins = <
-+ DRA7XX_CORE_IOPAD(0x3688, PIN_OUTPUT_PULLUP | MUX_MODE2) /* gpio6_14.dcan2_tx */
-+ DRA7XX_CORE_IOPAD(0x368C, PIN_INPUT_PULLUP | MUX_MODE2) /* gpio6_15.dcan2_rx */
-+ >;
-+ };
-+
-+ dcan2_pins_sleep: dcan2_pins_sleep {
-+ pinctrl-single,pins = <
-+ DRA7XX_CORE_IOPAD(0x3688, MUX_MODE15 | PULL_UP) /* gpio6_14.dcan2_tx.off */
-+ DRA7XX_CORE_IOPAD(0x368C, MUX_MODE15 | PULL_UP) /* gpio6_15.dcan2_rx.off */
-+ >;
-+ };
-+
- };
-
- &i2c1 {
-@@ -703,6 +717,13 @@
- memory-region = <&ipu1_memory_region>;
- };
-
-+&dcan2 {
-+ status = "ok";
-+ pinctrl-names = "default", "sleep";
-+ pinctrl-0 = <&dcan2_pins_default>;
-+ pinctrl-1 = <&dcan2_pins_sleep>;
-+};
-+
- &dsp1 {
- status = "okay";
- memory-region = <&dsp1_memory_region>;
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
index 2f6c449bc..88ac94b15 100644
--- a/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
@@ -1,11 +1 @@
require recipes-kernel/linux/linux-agl.inc
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-#-------------------------------------------------------------------------
-# patches for enabling dcan2 and fix dcan1 & dcan2 adresses
-
-SRC_URI += " \
- file://dcan2_pinmux_enable.patch \
-"
-
diff --git a/meta-agl-bsp/meta-ti/recipes-multimedia/pulseaudio/pulseaudio/dra7xx-evm-set-default-sink-source.patch b/meta-agl-bsp/meta-ti/recipes-multimedia/pulseaudio/pulseaudio/dra7xx-evm-set-default-sink-source.patch
deleted file mode 100644
index d45c5ef50..000000000
--- a/meta-agl-bsp/meta-ti/recipes-multimedia/pulseaudio/pulseaudio/dra7xx-evm-set-default-sink-source.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- pulseaudio-9.0/src/daemon/default.pa.in.orig 2017-08-04 00:07:08.833004893 +0300
-+++ pulseaudio-9.0/src/daemon/default.pa.in 2017-08-04 00:09:18.045102067 +0300
-@@ -162,8 +162,10 @@
- ])dnl
-
- ### Make some devices default
--#set-default-sink output
--#set-default-source input
-+# DRA7xx-EVM CPU Board Line-Out/Headphone
-+set-default-sink alsa_output.platform-sound0.analog-stereo
-+# DRA7xx-EVM CPU Board Microphone/Line-In
-+set-default-source alsa_input.platform-sound0.analog-stereo
-
- .ifexists module-router.so
- load-module module-router
diff --git a/meta-agl-bsp/meta-ti/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/meta-agl-bsp/meta-ti/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
deleted file mode 100644
index 37c4179e5..000000000
--- a/meta-agl-bsp/meta-ti/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/pulseaudio:"
-
-################### F I X M E ####################
-# FIXME pyro
-DISABLED_SRC_URI += " \
- file://dra7xx-evm-set-default-sink-source.patch \
-"