summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini15
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend15
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini
new file mode 100644
index 000000000..de3e7e8da
--- /dev/null
+++ b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini
@@ -0,0 +1,15 @@
+[core]
+shell=desktop-shell.so
+backend=drm-backend.so
+
+[shell]
+locking=true
+# Uncomment below to hide panel
+#panel-location=none
+
+[output]
+name=HDMI-A-1
+#mode=173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
+#mode=1920x1080
+#mode=1024x768
+#transform=90
diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..842c380a0
--- /dev/null
+++ b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston-renesas.ini \
+ "
+
+do_install_append() {
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston-renesas.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+}
+
+FILES_${PN} += " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+ "