summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb')
-rw-r--r--meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb b/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb
index 61086dfe7..7b6d50531 100644
--- a/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb
+++ b/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb
@@ -6,16 +6,19 @@ SECTION = "console/network"
DEPENDS = "dbus ncurses connman json-c"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=8c16666ae6c159876a0ba63099614381"
-SRC_URI = "git://gitlab.com/iotbzh/connman-json-client.git;protocol=https"
+SRC_URI = "git://gitlab.com/iotbzh/connman-json-client.git;protocol=https;branch=master \
+ file://stdbool-fixes.patch \
+ file://0001-Do-not-overwrite-CFLAGS.patch \
+ file://0001-Initialize-variables.patch \
+ "
SRCREV = "2b0f93ec9518c978c04807fe52e95315d6d80e6b"
inherit autotools pkgconfig
-EXTRA_AUTORECONF += " -i"
-EXTRA_OECONF += " --disable-optimization --enable-debug"
+EXTRA_AUTORECONF += " -vfi"
S = "${WORKDIR}/git"
@@ -24,4 +27,4 @@ do_install () {
install -Dm755 connman_ncurses ${D}${bindir}
}
-FILES_${PN} = "${bindir}/connman_ncurses"
+FILES:${PN} = "${bindir}/connman_ncurses"