summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb')
-rw-r--r--meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb b/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
index fc2c0c253..a23cd839a 100644
--- a/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
+++ b/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
@@ -10,19 +10,23 @@ SRC_URI = "\
file://canbus-can.network \
file://canbus-can-fd.network \
file://canbus-virtio.network \
+ file://canbus-can.link \
"
CANBUS_NETWORK_CONFIG ??= "canbus-can.network"
CANBUS_NETWORK_CONFIG:virtio-all ?= "canbus-virtio.network"
do_install() {
- # Install canbus network script
+ # Install CAN bus network configuration
install -d ${D}${nonarch_base_libdir}/systemd/network/
install -m 0644 ${WORKDIR}/${CANBUS_NETWORK_CONFIG} ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.network
+
+ # Install link configuration to bump queue size on physical CAN bus devices
+ install -m 0644 ${WORKDIR}/canbus-can.link ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.link
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
FILES:${PN} = " \
- ${nonarch_base_libdir}/systemd/network/*.network \
+ ${nonarch_base_libdir}/systemd/network/ \
"