summaryrefslogtreecommitdiffstats
path: root/meta-agl-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-core')
-rw-r--r--meta-agl-core/dynamic-layers/meta-selinux/recipes-core/systemd/systemd-selinux-relabel_1.0.bb7
-rw-r--r--meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb7
-rw-r--r--meta-agl-core/recipes-core/systemd/systemd_aglcore.inc6
-rw-r--r--meta-agl-core/recipes-graphics/rba/rba-config.bb5
-rw-r--r--meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf8
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb11
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb9
-rw-r--r--meta-agl-core/recipes-kernel/linux/linux-agl-config.inc2
8 files changed, 32 insertions, 23 deletions
diff --git a/meta-agl-core/dynamic-layers/meta-selinux/recipes-core/systemd/systemd-selinux-relabel_1.0.bb b/meta-agl-core/dynamic-layers/meta-selinux/recipes-core/systemd/systemd-selinux-relabel_1.0.bb
index 7e4f9783c..77020a630 100644
--- a/meta-agl-core/dynamic-layers/meta-selinux/recipes-core/systemd/systemd-selinux-relabel_1.0.bb
+++ b/meta-agl-core/dynamic-layers/meta-selinux/recipes-core/systemd/systemd-selinux-relabel_1.0.bb
@@ -6,6 +6,9 @@ SRC_URI = "file://systemd-selinux-relabel.service \
file://systemd-selinux-relabel.sh \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd allarch features_check
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -17,9 +20,9 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/systemd-selinux-relabel.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/systemd-selinux-relabel.service ${D}${systemd_system_unitdir}/
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/systemd-selinux-relabel.sh ${D}${sbindir}/
+ install -m 0755 ${UNPACKDIR}/systemd-selinux-relabel.sh ${D}${sbindir}/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb b/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
index a23cd839a..1624aea38 100644
--- a/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
+++ b/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
@@ -13,16 +13,19 @@ SRC_URI = "\
file://canbus-can.link \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
CANBUS_NETWORK_CONFIG ??= "canbus-can.network"
CANBUS_NETWORK_CONFIG:virtio-all ?= "canbus-virtio.network"
do_install() {
# Install CAN bus network configuration
install -d ${D}${nonarch_base_libdir}/systemd/network/
- install -m 0644 ${WORKDIR}/${CANBUS_NETWORK_CONFIG} ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.network
+ install -m 0644 ${UNPACKDIR}/${CANBUS_NETWORK_CONFIG} ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.network
# Install link configuration to bump queue size on physical CAN bus devices
- install -m 0644 ${WORKDIR}/canbus-can.link ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.link
+ install -m 0644 ${UNPACKDIR}/canbus-can.link ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.link
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc b/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc
index 9681329be..9fbe23708 100644
--- a/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc
+++ b/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc
@@ -20,15 +20,15 @@ PACKAGECONFIG:append:agl-devel = " coredump"
do_install:append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
- install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
+ install -m 644 -p -D ${UNPACKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
if [ "${VIRTUAL-RUNTIME_net_manager}" = "systemd" ]; then
# Install DHCP configuration for Ethernet adapters
- install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
+ install -m 644 ${UNPACKDIR}/wired.network ${D}${sysconfdir}/systemd/network
elif [ "${VIRTUAL-RUNTIME_net_manager}" = "connman" ]; then
# Disable systemd-networkd-wait-online by default
install -d ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d
- install -m 0644 ${WORKDIR}/wait-disable.conf ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/
+ install -m 0644 ${UNPACKDIR}/wait-disable.conf ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/
fi
}
diff --git a/meta-agl-core/recipes-graphics/rba/rba-config.bb b/meta-agl-core/recipes-graphics/rba/rba-config.bb
index cbed9df0c..53bb01bb1 100644
--- a/meta-agl-core/recipes-graphics/rba/rba-config.bb
+++ b/meta-agl-core/recipes-graphics/rba/rba-config.bb
@@ -4,12 +4,13 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
SRC_URI = "file://RBAModel.json"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install:append() {
install -d ${D}/${sysconfdir}/rba
- install -m 0644 ${WORKDIR}/RBAModel.json ${D}/${sysconfdir}/rba
+ install -m 0644 ${UNPACKDIR}/RBAModel.json ${D}/${sysconfdir}/rba
}
diff --git a/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf b/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf
index ee75c7335..e68dc7f0c 100644
--- a/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf
+++ b/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf
@@ -6,16 +6,16 @@ overrides (i.e. use the MACHINE name where "machine" is used below):
'''
do_configure:machine() {
- echo repaint-window=34 >> ${WORKDIR}/core.cfg
+ echo repaint-window=34 >> ${UNPACKDIR}/core.cfg
- echo transition-duration=300 >> ${WORKDIR}/ivishell.cfg
- echo cursor-theme=default >> ${WORKDIR}/ivishell.cfg
+ echo transition-duration=300 >> ${UNPACKDIR}/ivishell.cfg
+ echo cursor-theme=default >> ${UNPACKDIR}/ivishell.cfg
}
'''
or:
'''
do_configure:machine() {
- sed -i -e 's/drm-backend/fbdev-backend/' ${WORKDIR}/core.cfg
+ sed -i -e 's/drm-backend/fbdev-backend/' ${UNPACKDIR}/core.cfg
}
'''
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
index d8baf91f9..8400bc918 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
@@ -15,7 +15,8 @@ SRC_URI = "file://agl-compositor.service \
file://agl-compositor.conf.in \
"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
AGL_COMPOSITOR_ARGS ?= " --config ${sysconfdir}/xdg/weston/weston.ini --idle-time=0"
AGL_COMPOSITOR_USE_PIXMAN ??= "0"
@@ -25,10 +26,10 @@ AGL_COMPOSITOR_ARGS:append = " ${@bb.utils.contains("WESTON_USE_PIXMAN", "1", "
do_install() {
# Install systemd service
- install -D -p -m0644 ${WORKDIR}/agl-compositor.service ${D}${systemd_system_unitdir}/agl-compositor.service
- install -D -p -m0644 ${WORKDIR}/agl-compositor.socket ${D}${systemd_system_unitdir}/agl-compositor.socket
+ install -D -p -m0644 ${UNPACKDIR}/agl-compositor.service ${D}${systemd_system_unitdir}/agl-compositor.service
+ install -D -p -m0644 ${UNPACKDIR}/agl-compositor.socket ${D}${systemd_system_unitdir}/agl-compositor.socket
if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then
- install -D -p -m0644 ${WORKDIR}/agl-compositor-autologin ${D}${sysconfdir}/pam.d/agl-compositor-autologin
+ install -D -p -m0644 ${UNPACKDIR}/agl-compositor-autologin ${D}${sysconfdir}/pam.d/agl-compositor-autologin
fi
# Install systemd service drop-in with extra configuration
@@ -37,7 +38,7 @@ do_install() {
g=${f%.in}
if [ "${f}" != "${g}" ]; then
sed -e "s,@AGL_COMPOSITOR_ARGS@,${AGL_COMPOSITOR_ARGS},g" \
- ${WORKDIR}/${f} > ${WORKDIR}/${g}
+ ${UNPACKDIR}/${f} > ${WORKDIR}/${g}
fi
done
install -d ${D}${systemd_system_unitdir}/agl-compositor.service.d
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index f6b27a14b..3ada39f94 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -20,7 +20,8 @@ SRC_URI = " \
file://grpc-proxy.cfg \
"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
inherit update-alternatives
@@ -41,7 +42,7 @@ do_compile() {
# orientation configuration
rm -f ${WORKDIR}/weston.ini.default
for F in ${WESTON_FRAGMENTS}; do
- cat ${WORKDIR}/${F}.cfg >> ${WORKDIR}/weston.ini.default
+ cat ${UNPACKDIR}/${F}.cfg >> ${WORKDIR}/weston.ini.default
echo >> ${WORKDIR}/weston.ini.default
done
sed -i -e '$ d' ${WORKDIR}/weston.ini.default
@@ -65,8 +66,8 @@ do_compile() {
F="virtual-0"
INVF="virtual-180"
fi
- cat ${WORKDIR}/${F}.cfg >> ${WORKDIR}/weston.ini.landscape
- cat ${WORKDIR}/${INVF}.cfg >> ${WORKDIR}/weston.ini.landscape-inverted
+ cat ${UNPACKDIR}/${F}.cfg >> ${WORKDIR}/weston.ini.landscape
+ cat ${UNPACKDIR}/${INVF}.cfg >> ${WORKDIR}/weston.ini.landscape-inverted
echo >> ${WORKDIR}/weston.ini.landscape
echo >> ${WORKDIR}/weston.ini.landscape-inverted
done
diff --git a/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc b/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc
index 4799a6180..8205e6ff7 100644
--- a/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc
+++ b/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc
@@ -32,7 +32,7 @@ AGL_KERNEL_SRC ?= "${@' '.join(['file://' + x for x in d.getVar('AGL_KCONFIG_FRA
SRC_URI:append = " ${AGL_KERNEL_SRC}"
# For meta-ti and meta-qcom
-KERNEL_CONFIG_FRAGMENTS ?= "${@' '.join(['${WORKDIR}/' + x for x in d.getVar('AGL_KCONFIG_FRAGMENTS').split()])}"
+KERNEL_CONFIG_FRAGMENTS ?= "${@' '.join(['${UNPACKDIR}/' + x for x in d.getVar('AGL_KCONFIG_FRAGMENTS').split()])}"
# Extra configuration options for the AGL kernel
AGL_KCONFIG_FRAGMENTS += " \