summaryrefslogtreecommitdiffstats
path: root/meta-agl-distro
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-distro')
-rw-r--r--meta-agl-distro/conf/distro/poky-agl-next.inc1
-rw-r--r--meta-agl-distro/conf/distro/poky-agl.conf28
-rw-r--r--meta-agl-distro/conf/layer.conf2
3 files changed, 22 insertions, 9 deletions
diff --git a/meta-agl-distro/conf/distro/poky-agl-next.inc b/meta-agl-distro/conf/distro/poky-agl-next.inc
new file mode 100644
index 000000000..c5798aa55
--- /dev/null
+++ b/meta-agl-distro/conf/distro/poky-agl-next.inc
@@ -0,0 +1 @@
+AGL_BRANCH_pn-agl-service-gps = "next"
diff --git a/meta-agl-distro/conf/distro/poky-agl.conf b/meta-agl-distro/conf/distro/poky-agl.conf
index 4ae2b714b..63a421645 100644
--- a/meta-agl-distro/conf/distro/poky-agl.conf
+++ b/meta-agl-distro/conf/distro/poky-agl.conf
@@ -42,7 +42,7 @@ MAINTAINER = "AGL <automotive-discussions@lists.linuxfoundation.org>"
TARGET_VENDOR = "-agl"
# Override these in poky based distros
-AGL_DEFAULT_DISTRO_FEATURES = "largefile systemd opengl wayland pam bluetooth bluez5 3g"
+AGL_DEFAULT_DISTRO_FEATURES = "largefile systemd opengl wayland pam bluetooth bluez5 3g polkit"
POKY_DEFAULT_DISTRO_FEATURES := "${AGL_DEFAULT_DISTRO_FEATURES}"
OVERRIDES .= ":${DISTRO_CODENAME}"
@@ -94,14 +94,17 @@ DISTRO_FEATURES_APPEND = " "
DISTRO_FEATURES_remove = "x11"
DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit pulseaudio"
+# Prefer linux-yocto 4.19 LTS version by default
+PREFERRED_VERSION_linux-yocto = "4.19%"
+
# Prefer GStreamer 1.14.x by default
-PREFERRED_VERSION_gstreamer1.0 ?= "1.14.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-bad ?= "1.14.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-base ?= "1.14.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-good ?= "1.14.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-ugly ?= "1.14.%"
-PREFERRED_VERSION_gstreamer1.0-libav ?= "1.14.%"
-PREFERRED_VERSION_gstreamer1.0-omx ?= "1.14.%"
+PREFERRED_VERSION_gstreamer1.0 ?= "1.16.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-bad ?= "1.16.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-base ?= "1.16.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-good ?= "1.16.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-ugly ?= "1.16.%"
+PREFERRED_VERSION_gstreamer1.0-libav ?= "1.16.%"
+PREFERRED_VERSION_gstreamer1.0-omx ?= "1.16.%"
# Prefer libjpeg-turbo
PREFERRED_PROVIDER_jpeg = "libjpeg-turbo"
@@ -175,3 +178,12 @@ PREFERRED_RPROVIDER_virtual/navigation ?= "ondemandnavi"
# Set preferred provider for low-can device mapping configuration
PREFERRED_RPROVIDER_virtual/low-can-dev-mapping ?= "dev-mapping"
+
+# Mask upstream meta-security bbappend that interferes with non-linux-yocto
+# kernels due to the bug of having two wildcards, which bitbake does not
+# support. Not having it is not an issue, since there is also explicit
+# enabling of required security features done by meta-agl/meta-security.
+BBMASK += "meta-security/recipes-kernel/linux/linux-%_5.%.bbappend"
+
+# Temporarily pull in some next branch specific over-rides
+include poky-agl-next.inc
diff --git a/meta-agl-distro/conf/layer.conf b/meta-agl-distro/conf/layer.conf
index 3c60fd4c7..7028ca3e2 100644
--- a/meta-agl-distro/conf/layer.conf
+++ b/meta-agl-distro/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILE_COLLECTIONS += "agl-distro"
BBFILE_PATTERN_agl-distro = "^${LAYERDIR}/"
BBFILE_PRIORITY_agl-distro = "70"
-LAYERSERIES_COMPAT_agl-distro = "thud"
+LAYERSERIES_COMPAT_agl-distro = "zeus"