summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend')
-rw-r--r--meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend b/meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend
new file mode 100644
index 000000000..bdc196b6f
--- /dev/null
+++ b/meta-agl-profile-core/recipes-core/psplash/psplash_git.bbappend
@@ -0,0 +1,27 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://psplash-colors.h \
+ file://psplash-start.service \
+ file://psplash-quit.service \
+ file://psplash-anim \
+ "
+
+SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
+
+inherit systemd
+
+SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
+SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
+
+do_configure_append () {
+ cd ${S}
+ cp ../psplash-colors.h ./
+}
+
+do_install_append () {
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${systemd_unitdir}/system
+ install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
+ fi
+ install -m 755 ${WORKDIR}/psplash-anim ${D}/${bindir}
+}