summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-ivi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-core/recipes-ivi')
-rw-r--r--meta-agl-profile-core/recipes-ivi/images/agl-image-ivi-crosssdk.bb19
-rw-r--r--meta-agl-profile-core/recipes-ivi/images/agl-image-ivi-qa.bb14
-rw-r--r--meta-agl-profile-core/recipes-ivi/images/agl-image-ivi.bb17
-rw-r--r--meta-agl-profile-core/recipes-ivi/images/agl-image-ivi.inc3
-rw-r--r--meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-image-ivi.bb31
-rw-r--r--meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-automotive.bb14
-rw-r--r--meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-connectivity.bb19
-rw-r--r--meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-graphics.bb14
-rw-r--r--meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-kernel.bb14
-rw-r--r--meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-multimedia.bb17
-rw-r--r--meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb14
-rw-r--r--meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-os-commonlibs.bb14
-rw-r--r--meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-security.bb14
-rw-r--r--meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-speech-services.bb14
14 files changed, 218 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi-crosssdk.bb b/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi-crosssdk.bb
new file mode 100644
index 000000000..0303d051d
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi-crosssdk.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Cross SDK of AGL Distribution for IVI profile"
+
+DESCRIPTION = "Basic image for baseline of AGL Distribution for IVI profile. \
+It includes the full meta-toolchain, plus developement headers and libraries \
+to form a standalone cross SDK."
+
+require agl-image-ivi.bb
+
+LICENSE = "MIT"
+
+IMAGE_FEATURES += "dev-pkgs"
+IMAGE_INSTALL += "kernel-dev"
+
+inherit populate_sdk
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs
diff --git a/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi-qa.bb b/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi-qa.bb
new file mode 100644
index 000000000..017439454
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi-qa.bb
@@ -0,0 +1,14 @@
+SUMMARY = "A basic system of AGL distribution of IVI profile for Quality Assurance(QA)"
+
+DESCRIPTION = "A basic set of AGL Distribution. This image also has additional \
+packages (e.g. commandline tools) for Quality Assurance(QA)."
+
+require agl-image-ivi.bb
+
+LICENSE = "MIT"
+
+IMAGE_INSTALL_append = " \
+ packagegroup-agl-test \
+ packagegroup-ivi-common-test \
+ "
+
diff --git a/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi.bb b/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi.bb
new file mode 100644
index 000000000..dd4f89b15
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi.bb
@@ -0,0 +1,17 @@
+SUMMARY = "A basic system of AGL distribution of IVI profile"
+
+DESCRIPTION = "Basic image for baseline of AGL Distribution for IVI profile."
+
+require agl-image-ivi.inc
+
+LICENSE = "MIT"
+
+IMAGE_INSTALL_append = "\
+ packagegroup-agl-image-ivi \
+ "
+
+DISTRO_FEATURES_append = " agl-core-image-profile"
+
+IMAGE_INSTALL += "\
+ agl-desktop-config \
+ "
diff --git a/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi.inc b/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi.inc
new file mode 100644
index 000000000..0b564840b
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/images/agl-image-ivi.inc
@@ -0,0 +1,3 @@
+require recipes-core/images/agl-image-minimal.inc
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
diff --git a/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-image-ivi.bb b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-image-ivi.bb
new file mode 100644
index 000000000..075af913a
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-image-ivi.bb
@@ -0,0 +1,31 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required for AGL Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-image-ivi \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-image-minimal \
+"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-ivi-automotive \
+ packagegroup-agl-ivi-connectivity \
+ packagegroup-agl-ivi-graphics \
+ packagegroup-agl-ivi-multimedia \
+ packagegroup-agl-ivi-navi-lbs \
+ packagegroup-agl-ivi-os-commonlibs \
+ packagegroup-agl-ivi-speech-services \
+ packagegroup-agl-ivi-security \
+ packagegroup-agl-ivi-kernel \
+ "
+
+RDEPENDS_${PN} += "\
+ agl-login-manager \
+ "
diff --git a/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-automotive.bb b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-automotive.bb
new file mode 100644
index 000000000..f7221517f
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-automotive.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Automotive Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-automotive \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-connectivity.bb b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-connectivity.bb
new file mode 100644
index 000000000..664180d55
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-connectivity.bb
@@ -0,0 +1,19 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Connectivity Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-connectivity \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ ofono \
+ rtl-sdr \
+ rygel \
+ rygel-plugin-media-export \
+ rygel-plugin-lms \
+ "
diff --git a/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-graphics.bb b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-graphics.bb
new file mode 100644
index 000000000..d7650564b
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-graphics.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Graphics Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-graphics \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-kernel.bb b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-kernel.bb
new file mode 100644
index 000000000..be51817b7
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-kernel.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Kernel Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-kernel \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-multimedia.bb b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-multimedia.bb
new file mode 100644
index 000000000..11536405e
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-multimedia.bb
@@ -0,0 +1,17 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Multimedia Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-multimedia \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ gstreamer1.0-plugins-base-meta \
+ gstreamer1.0-plugins-good-meta \
+ lightmediascanner-meta \
+ "
diff --git a/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb
new file mode 100644
index 000000000..b7f47eecc
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The packages of middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Navigation and Location Based Services Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-navi-lbs \
+ "
+
+RDEPENDS_${PN} += "\
+ gpsd \
+ geoclue \
+ "
diff --git a/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-os-commonlibs.bb b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-os-commonlibs.bb
new file mode 100644
index 000000000..0a9de8d5f
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-os-commonlibs.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The packages of middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Operating System and Common libraries Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-os-commonlibs \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-security.bb b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-security.bb
new file mode 100644
index 000000000..f651c50cd
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-security.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The packages of middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Security Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-security \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-speech-services.bb b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-speech-services.bb
new file mode 100644
index 000000000..eccebee9f
--- /dev/null
+++ b/meta-agl-profile-core/recipes-ivi/packagegroups/packagegroup-agl-ivi-speech-services.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The packages of middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Speech Services Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-speech-services \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "