summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-support/udisks
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-core/recipes-support/udisks')
-rw-r--r--meta-agl-profile-core/recipes-support/udisks/files/99-udisks2.rules5
-rw-r--r--meta-agl-profile-core/recipes-support/udisks/files/automount.service9
-rw-r--r--meta-agl-profile-core/recipes-support/udisks/files/automount.sh93
-rw-r--r--meta-agl-profile-core/recipes-support/udisks/udisks2_%.bbappend26
4 files changed, 0 insertions, 133 deletions
diff --git a/meta-agl-profile-core/recipes-support/udisks/files/99-udisks2.rules b/meta-agl-profile-core/recipes-support/udisks/files/99-udisks2.rules
deleted file mode 100644
index 996e43439..000000000
--- a/meta-agl-profile-core/recipes-support/udisks/files/99-udisks2.rules
+++ /dev/null
@@ -1,5 +0,0 @@
-# UDISKS_FILESYSTEM_SHARED
-# ==1: mount filesystem to a shared directory (/media/VolumeName)
-# ==0: mount filesystem to a private directory (/run/media/$USER/VolumeName)
-# See udisks(8)
-ENV{ID_FS_USAGE}=="filesystem|other|crypto", ENV{UDISKS_FILESYSTEM_SHARED}="1"
diff --git a/meta-agl-profile-core/recipes-support/udisks/files/automount.service b/meta-agl-profile-core/recipes-support/udisks/files/automount.service
deleted file mode 100644
index b16515196..000000000
--- a/meta-agl-profile-core/recipes-support/udisks/files/automount.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=Automount Disk Manager
-After=udisks2.service
-
-[Service]
-ExecStart=/usr/libexec/automount.sh
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-agl-profile-core/recipes-support/udisks/files/automount.sh b/meta-agl-profile-core/recipes-support/udisks/files/automount.sh
deleted file mode 100644
index 236791910..000000000
--- a/meta-agl-profile-core/recipes-support/udisks/files/automount.sh
+++ /dev/null
@@ -1,93 +0,0 @@
-#!/bin/sh
-
-MOUNT_OPTIONS_DEFAULT="ro,noexec"
-MOUNT_OPTIONS_VFAT="umask=0022"
-MOUNT_OPTIONS_EXT=""
-MOUNT_OPTIONS_NTFS=""
-MOUNT_OPTIONS_ISO9660=""
-
-VERBOSE=false
-
-# Source a configuration file that can override mount options if exists
-[ -f /etc/automount.conf ] && . /etc/automount.conf
-
-mount_device() {
- MOUNT_OPTIONS=""
- FSTYPE="$( udevadm info "${1}" "${2}" | awk -v FS== '/ID_FS_TYPE/ {print $2}' )"
- DEVNAME="$( udevadm info "${1}" "${2}" | awk -v FS== '/DEVNAME/ {print $2}' )"
- case $FSTYPE in
- vfat)
- MOUNT_OPTIONS="${MOUNT_OPTIONS_VFAT}"
- ;;
- ext[2-4])
- MOUNT_OPTIONS="${MOUNT_OPTIONS_EXT}"
- ;;
- ntfs)
- MOUNT_OPTIONS="${MOUNT_OPTIONS_NTFS}"
- ;;
- iso9660)
- MOUNT_OPTIONS="${MOUNT_OPTIONS_ISO9660}"
- ;;
- "")
- if $VERBOSE; then
- echo "[INFO][${DEVNAME}] Not a partition with a filesystem!"
- fi
- return
- ;;
- *)
- echo "[WARNING][${DEVNAME}] The filesystem '${FSTYPE}' is not supported!"
- return
- ;;
- esac
-
- if [ -n "${MOUNT_OPTIONS_DEFAULT}" ]; then
- if [ -z "${MOUNT_OPTIONS}" ]; then
- MOUNT_OPTIONS="${MOUNT_OPTIONS_DEFAULT}"
- else
- MOUNT_OPTIONS="${MOUNT_OPTIONS_DEFAULT},${MOUNT_OPTIONS}"
- fi
- fi
- if $VERBOSE; then
- echo "[INFO][${DEVNAME}] Mounting a ${FSTYPE}'s filesystem with options: ${MOUNT_OPTIONS}"
- fi
-
- if command -v udisksctl > /dev/null 2>&1; then
- if [ -n "${MOUNT_OPTIONS}" ]; then
- MOUNT_OPTIONS="-o ${MOUNT_OPTIONS}"
- fi
- udisksctl mount -t "${FSTYPE}" -b "${DEVNAME}" ${MOUNT_OPTIONS}
- elif command -v udisks >/dev/null 2>&1; then
- if [ -n "${MOUNT_OPTIONS}" ]; then
- MOUNT_OPTIONS="--mount-options ${MOUNT_OPTIONS}"
- fi
- udisks --mount-fstype "${FSTYPE}" --mount "${DEVNAME}" ${MOUNT_OPTIONS}
- else
- echo "[ERROR] Unable to find binary for mounting ${DEVNAME}" >&2
- return
- fi
- if [ "$?" -ne "0" ]; then
- echo "[ERROR] Failed to mount the device ${DEVNAME} of type ${FSTYPE} with options ${MOUNT_OPTIONS}" >&2
- fi
-}
-
-# At startup, remove empty directories that may exists
-rmdir /media/* > /dev/null 2>&1
-
-# Mount already plugged devices
-for DEVICE in $( lsblk -dn | cut -d' ' -f1 ); do
- REMOVABLE=$( cat "/sys/block/${DEVICE}/removable" )
- if [ "${REMOVABLE}" -eq "1" ]; then
- for PART in "/dev/${DEVICE}"*; do
- mount_device -n "${PART}"
- done
- fi
-done
-
-# Wait for plug events and mount devices
-stdbuf -oL -- udevadm monitor --udev -s block |
-while read -r -- _ _ EVENT DEVPATH _
-do
- if [ "${EVENT}" = "add" ]; then
- mount_device -p "/sys/${DEVPATH}"
- fi
-done
diff --git a/meta-agl-profile-core/recipes-support/udisks/udisks2_%.bbappend b/meta-agl-profile-core/recipes-support/udisks/udisks2_%.bbappend
deleted file mode 100644
index 34756f480..000000000
--- a/meta-agl-profile-core/recipes-support/udisks/udisks2_%.bbappend
+++ /dev/null
@@ -1,26 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRC_URI += "file://automount.service \
- file://automount.sh \
- file://99-udisks2.rules \
-"
-
-SYSTEMD_AUTO_ENABLE = "enable"
-SYSTEMD_SERVICE_${PN} += "automount.service"
-
-do_install_append () {
- sed -i 's/^WantedBy=.*/WantedBy=multi-user.target/' ${D}${systemd_unitdir}/system/udisks2.service
-
- install -d ${D}${base_libdir}/systemd/system
- install -m 0644 ${WORKDIR}/automount.service ${D}${systemd_unitdir}/system
-
- install -d ${D}${libexecdir}
- install -m 0755 ${WORKDIR}/automount.sh ${D}${libexecdir}/automount.sh
-
- install -d ${D}${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/99-udisks2.rules ${D}${sysconfdir}/udev/rules.d
-}
-
-FILES_${PN} += "${base_libdir}/systemd/system/automount.service \
- ${libexecdir}/automount.sh \
-"