summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-demo/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-demo/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch')
-rw-r--r--meta-agl-profile-demo/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-profile-demo/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch b/meta-agl-profile-demo/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch
new file mode 100644
index 000000000..5bf6bf88e
--- /dev/null
+++ b/meta-agl-profile-demo/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch
@@ -0,0 +1,30 @@
+From 8080b7395c1638baee60fb3c46667f21e00b87fb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Erik=20Bot=C3=B6?= <erik.boto@pelagicore.com>
+Date: Fri, 4 Apr 2014 10:59:18 +0200
+Subject: [PATCH 1/4] Fix build with systemd >= 209
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Inappropriate [Configuration Specific]
+Signed-off-by: Erik Botö <erik.boto@pelagicore.com>
+---
+ src/system/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/system/CMakeLists.txt b/src/system/CMakeLists.txt
+index ce87914..1d0d224 100644
+--- a/src/system/CMakeLists.txt
++++ b/src/system/CMakeLists.txt
+@@ -23,7 +23,7 @@ set(dlt_system_SRCS dlt-system.c dlt-system-options.c dlt-system-process-handlin
+ dlt-system-syslog.c dlt-system-watchdog.c dlt-system-journal.c)
+ add_executable(dlt-system ${dlt_system_SRCS} ${systemd_SRCS})
+ if(WITH_SYSTEMD_JOURNAL)
+- target_link_libraries(dlt-system dlt ${ZLIB_LIBRARIES} systemd-journal systemd-id128)
++ target_link_libraries(dlt-system dlt ${ZLIB_LIBRARIES} systemd)
+ else(WITH_SYSTEMD_JOURNAL)
+ target_link_libraries(dlt-system dlt ${ZLIB_LIBRARIES})
+ endif(WITH_SYSTEMD_JOURNAL)
+--
+1.9.3
+