summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-demo/recipes-kernel/mocca-usb/mocca-usb.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-demo/recipes-kernel/mocca-usb/mocca-usb.bb')
-rw-r--r--meta-agl-profile-demo/recipes-kernel/mocca-usb/mocca-usb.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-agl-profile-demo/recipes-kernel/mocca-usb/mocca-usb.bb b/meta-agl-profile-demo/recipes-kernel/mocca-usb/mocca-usb.bb
new file mode 100644
index 000000000..cf4e5856b
--- /dev/null
+++ b/meta-agl-profile-demo/recipes-kernel/mocca-usb/mocca-usb.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Build USB driver for MOCCA box"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+inherit module
+
+PV = "0.1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/can-lin/;protocol=https;branch=${AGL_BRANCH}"
+S = "${WORKDIR}/git/Usb-Driver"
+SRCREV = "02ba272c0eb51b06160307b6cb71f91684772c8c"
+
+# The inherit of module.bbclass will automatically name module packages with
+# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "mocca_usb" > ${D}${sysconfdir}/modules-load.d/mocca_usb.conf
+ fi
+}