summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch31
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-added-ivi-id-agent.patch20
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0003-ivi-controller-load-id-agent-module.patch19
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0004-ivi-ilmcontrol-added-focus-notification.patch7
4 files changed, 27 insertions, 50 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch
index feeef0e22..7ea0b6e9b 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch
@@ -3,33 +3,20 @@ From: Michael Teyfel <mteyfel@de.adit-jv.com>
Date: Fri, 12 Oct 2018 17:12:24 +0200
Subject: [PATCH 1/3] Added ivi-id-agent to CMake
+Reworked for wayland-ivi-extension 2.2.0 by Scott Murray.
+
Signed-off-by: Michael Teyfel <mteyfel@de.adit-jv.com>
----
- CMakeLists.txt | 4 ++++
- 1 file changed, 4 insertions(+)
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c82136e..33662b9 100644
+index 7d0044a..988fc89 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -23,6 +23,9 @@ SET(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
-
- project(wayland-ivi-extension)
-
-+find_package(PkgConfig REQUIRED)
-+pkg_check_modules(WESTON weston>=2.0.0 REQUIRED)
-+
- SET(IVI_EXTENSION_VERSION 2.0.2)
- SET(ILM_API_VERSION 2.0.2)
-
-@@ -35,6 +38,7 @@ add_subdirectory(ivi-layermanagement-api/ilmClient)
- add_subdirectory(ivi-layermanagement-api/ilmControl)
- add_subdirectory(ivi-layermanagement-api/test)
+@@ -40,6 +40,7 @@ add_subdirectory(ivi-layermanagement-api/test)
add_subdirectory(ivi-layermanagement-examples)
+ add_subdirectory(ivi-layermanagement-api/ilmInput)
+ add_subdirectory(ivi-input-modules/ivi-input-controller)
+add_subdirectory(ivi-id-agent-modules/ivi-id-agent)
- if(WITH_ILM_INPUT)
- add_subdirectory(ivi-input-api/ilmInput)
---
-2.7.4
-
+
+ #=============================================================================================
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-added-ivi-id-agent.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-added-ivi-id-agent.patch
index 2b78357fe..c39c23982 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-added-ivi-id-agent.patch
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-added-ivi-id-agent.patch
@@ -35,19 +35,14 @@ weston: https://github.com/mtey/weston/tree/xdg_support_ivi_id_agent
Since libweston-desktop is used to introduce desktop-surface support,
xdg-protocol is supported.
+Reworked for wayland-ivi-extension 2.2.0 by Scott Murray.
+
Signed-off-by: Michael Teyfel <mteyfel@de.adit-jv.com>
----
- ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt | 69 ++++
- .../ivi-id-agent/src/ivi-id-agent.c | 381 +++++++++++++++++++++
- ivi-id-agent-modules/ivi-id-agent/weston.ini.in | 20 ++
- 3 files changed, 470 insertions(+)
- create mode 100644 ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
- create mode 100644 ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c
- create mode 100644 ivi-id-agent-modules/ivi-id-agent/weston.ini.in
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
diff --git a/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt b/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
new file mode 100644
-index 0000000..2def105
+index 0000000..7354a7e
--- /dev/null
+++ b/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
@@ -0,0 +1,69 @@
@@ -76,9 +71,9 @@ index 0000000..2def105
+
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(WAYLAND_SERVER wayland-server REQUIRED)
-+pkg_check_modules(WESTON weston>=2.0.0 REQUIRED)
++pkg_check_modules(WESTON weston>=5.0.0 REQUIRED)
+pkg_check_modules(PIXMAN pixman-1 REQUIRED)
-+pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-2 REQUIRED)
++pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-5 REQUIRED)
+
+find_package(Threads REQUIRED)
+
@@ -533,6 +528,3 @@ index 0000000..48a196c
+[desktop-app-default]
+default-surface-id=2000000
+default-surface-id-max=2001000
---
-2.7.4
-
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0003-ivi-controller-load-id-agent-module.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0003-ivi-controller-load-id-agent-module.patch
index 06fe7843a..8985879b0 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0003-ivi-controller-load-id-agent-module.patch
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0003-ivi-controller-load-id-agent-module.patch
@@ -3,16 +3,16 @@ From: Michael Teyfel <mteyfel@de.adit-jv.com>
Date: Fri, 12 Oct 2018 16:57:24 +0200
Subject: [PATCH 3/3] ivi-controller: load id-agent module
+Reworked for wayland-ivi-extension 2.2.0 by Scott Murray.
+
Signed-off-by: Michael Teyfel <mteyfel@de.adit-jv.com>
----
- weston-ivi-shell/src/ivi-controller.c | 39 +++++++++++++++++++++++++++++++++++
- 1 file changed, 39 insertions(+)
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
diff --git a/weston-ivi-shell/src/ivi-controller.c b/weston-ivi-shell/src/ivi-controller.c
-index 6d95c88..f6ac174 100644
+index 8faec2a..8fa51f4 100644
--- a/weston-ivi-shell/src/ivi-controller.c
+++ b/weston-ivi-shell/src/ivi-controller.c
-@@ -2164,6 +2164,41 @@ load_input_module(struct ivishell *shell)
+@@ -2154,6 +2154,41 @@ load_input_module(struct ivishell *shell)
return 0;
}
@@ -54,9 +54,9 @@ index 6d95c88..f6ac174 100644
static void
launch_client_process(void *data)
{
-@@ -2229,6 +2264,10 @@ controller_module_init(struct weston_compositor *compositor,
- return -1;
- }
+@@ -2221,6 +2256,10 @@ wet_module_init(struct weston_compositor *compositor,
+ shell->destroy_listener.notify = ivi_shell_destroy;
+ wl_signal_add(&compositor->destroy_signal, &shell->destroy_listener);
+ if (load_id_agent_module(shell) < 0) {
+ weston_log("ivi-controller: id-agent module not loaded\n");
@@ -65,6 +65,3 @@ index 6d95c88..f6ac174 100644
if (shell->bkgnd_surface_id && shell->ivi_client_name) {
loop = wl_display_get_event_loop(compositor->wl_display);
wl_event_loop_add_idle(loop, launch_client_process, shell);
---
-2.7.4
-
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0004-ivi-ilmcontrol-added-focus-notification.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0004-ivi-ilmcontrol-added-focus-notification.patch
index a665c060f..05d1cc238 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0004-ivi-ilmcontrol-added-focus-notification.patch
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0004-ivi-ilmcontrol-added-focus-notification.patch
@@ -11,10 +11,10 @@ index a88f2b0..12a2017 100644
} t_ilm_notification_mask;
diff --git a/ivi-layermanagement-api/ilmControl/src/ilm_control_wayland_platform.c b/ivi-layermanagement-api/ilmControl/src/ilm_control_wayland_platform.c
-index 9b4762b..5104459 100644
+index a912e50..5166839 100644
--- a/ivi-layermanagement-api/ilmControl/src/ilm_control_wayland_platform.c
+++ b/ivi-layermanagement-api/ilmControl/src/ilm_control_wayland_platform.c
-@@ -779,6 +779,12 @@ input_listener_input_focus(void *data,
+@@ -819,6 +819,12 @@ input_listener_input_focus(void *data,
surf_ctx->prop.focus |= device;
else
surf_ctx->prop.focus &= ~device;
@@ -25,4 +25,5 @@ index 9b4762b..5104459 100644
+ ILM_NOTIFICATION_FOCUS);
+ }
}
- } \ No newline at end of file
+ }
+