summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston_2.0.0.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston_2.0.0.patch')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston_2.0.0.patch19
1 files changed, 6 insertions, 13 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston_2.0.0.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston_2.0.0.patch
index bd1a72b0f..3a59ba0c8 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston_2.0.0.patch
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston_2.0.0.patch
@@ -4,18 +4,14 @@ Date: Wed, 31 May 2017 22:48:18 +0000
Subject: [PATCH] Allow regular users to launch Weston
Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
----
- configure.ac | 6 ++++++
- libweston/launcher-direct.c | 2 ++
- 2 files changed, 8 insertions(+)
diff --git a/configure.ac b/configure.ac
-index 7e84c14..8b3e17e 100644
+index 50f8e013..2043b9b0 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -155,6 +155,12 @@ if test x$enable_xkbcommon = xyes; then
- true)
- fi
+@@ -156,6 +156,12 @@ PKG_CHECK_MODULES(XKBCOMMON_COMPOSE, [xkbcommon >= 0.5.0],
+ [AC_DEFINE(HAVE_XKBCOMMON_COMPOSE, 1,
+ [Define if xkbcommon is 0.5.0 or newer])],true)
+AC_ARG_ENABLE(sys-uid, [ --enable-sys-uid],,
+ enable_sys_uid=no)
@@ -27,10 +23,10 @@ index 7e84c14..8b3e17e 100644
enable_setuid_install=yes)
AM_CONDITIONAL(ENABLE_SETUID_INSTALL, test x$enable_setuid_install = xyes)
diff --git a/libweston/launcher-direct.c b/libweston/launcher-direct.c
-index 4fc1c3c..8f16a69 100644
+index e0ce6d63..d0db9bb5 100644
--- a/libweston/launcher-direct.c
+++ b/libweston/launcher-direct.c
-@@ -275,8 +275,10 @@ launcher_direct_connect(struct weston_launcher **out, struct weston_compositor *
+@@ -283,8 +283,10 @@ launcher_direct_connect(struct weston_launcher **out, struct weston_compositor *
{
struct launcher_direct *launcher;
@@ -41,6 +37,3 @@ index 4fc1c3c..8f16a69 100644
launcher = zalloc(sizeof(*launcher));
if (launcher == NULL)
---
-2.7.4
-