summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-core/systemd/systemd_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-core/systemd/systemd_%.bbappend')
-rw-r--r--meta-agl/recipes-core/systemd/systemd_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-agl/recipes-core/systemd/systemd_%.bbappend b/meta-agl/recipes-core/systemd/systemd_%.bbappend
index ef877c0c1..a3213dc9c 100644
--- a/meta-agl/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl/recipes-core/systemd/systemd_%.bbappend
@@ -1,6 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://e2fsck.conf \
+ file://automount-rules \
+ file://mount.sh \
${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
"
@@ -13,6 +15,11 @@ do_install_append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'automount', 'true', 'false', d)}; then
+ install -m 644 -p -D ${WORKDIR}/automount-rules ${D}${sysconfdir}/udev/rules.d/automount.rules
+ install -m 755 -p -D ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
+ fi
+
if ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','true','false',d)}; then
# Install DHCP configuration for Ethernet adapters
install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network