summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-core/systemd/systemd_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-core/systemd/systemd_%.bbappend')
-rw-r--r--meta-agl/recipes-core/systemd/systemd_%.bbappend13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta-agl/recipes-core/systemd/systemd_%.bbappend b/meta-agl/recipes-core/systemd/systemd_%.bbappend
index 96ca6c69d..ef877c0c1 100644
--- a/meta-agl/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl/recipes-core/systemd/systemd_%.bbappend
@@ -1,17 +1,22 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://e2fsck.conf \
- file://wired.network \
+ ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
"
# enable networkd/resolved support
-PACKAGECONFIG_append_pn-systemd = " networkd resolved"
+PACKAGECONFIG_append_pn-systemd = " \
+ ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','networkd resolved','',d)} \
+"
do_install_append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
- # Install DHCP configuration for Ethernet adapters
- install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
+
+ if ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','true','false',d)}; then
+ # Install DHCP configuration for Ethernet adapters
+ install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
+ fi
}
FILES_${PN} += "${sysconfdir}/e2fsck.conf "