summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf')
-rw-r--r--meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf b/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
new file mode 100644
index 000000000..740ac56d1
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
@@ -0,0 +1,36 @@
+#Generate a weston.ini file:
+
+To generate the weston.ini file:
+
+'''
+[core]
+backend=desktop-shell.so
+shell=ivi-shell.so
+'''
+
+Just create a Variable Flag:
+
+'''
+WESTONCORE[backend]??="drm-backend.so"
+WESTONCORE[shell]??="desktop-shell.so"
+'''
+
+And add it to the Variable Flag WESTONSECTION, with the name of the section:
+'''
+WESTONSECTION[WESTONCORE]?="core"
+'''
+
+#You can custumize weston.ini by create a weston-ini-conf.bbappend:
+
+'''
+WESTONCORE[repaint-window] ??= "34"
+'''
+
+This will generate weston.ini file:
+
+'''
+[core]
+backend=desktop-shell.so
+shell=ivi-shell.so
+repaint-window=34
+'''