summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf')
-rw-r--r--meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf42
1 files changed, 20 insertions, 22 deletions
diff --git a/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf b/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
index eb30a9a96..bbd5a80c4 100644
--- a/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
+++ b/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
@@ -1,36 +1,34 @@
-#Generate a weston.ini file:
+##Generate a weston.ini file:
-To generate the weston.ini file:
+To modify any of the default sections (core, shell, ivi-shell), add a
+do_configure() function to your bbappend:
'''
-[core]
-backend=drm-backend.so
-shell=desktop-shell.so
-'''
-
-Just create a Variable Flag:
+do_configure() {
+ echo repaint-window=34 >> ${WORKDIR}/core.cfg
+ echo transition-duration=300 >> ${WORKDIR}/ivishell.cfg
+ echo cursor-theme=default >> ${WORKDIR}/ivishell.cfg
+}
'''
-WESTONCORE[backend]??="drm-backend.so"
-WESTONCORE[shell]??="desktop-shell.so"
-'''
-
-And add it to the Variable Flag WESTONSECTION, with the name of the section:
+or:
'''
-WESTONSECTION[WESTONCORE]?="core"
+do_configure() {
+ sed -i -e 's/drm-backend/fbdev-backend/' ${WORKDIR}/core.cfg
+}
'''
-#You can custumize weston.ini by create a weston-ini-conf.bbappend:
+To change the display from the default assumption of an HDMI-1-A connected
+screen that needs to be rotated 270 degrees:
'''
-WESTONCORE[repaint-window] ??= "34"
+SRC_URI_remove = "file://hdmi-a-1-270.cfg"
+SRC_URI += "file://hdmi-a-1-90.cfg"
'''
-This will generate weston.ini file:
-
+To add new sections just list them in SRC_URI:
'''
-[core]
-backend=drm-backend.so
-shell=ivi-shell.so
-repaint-window=34
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://dsi.cfg"
'''