summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-core/systemd/systemd/wired.network5
-rw-r--r--meta-agl/recipes-core/systemd/systemd_%.bbappend14
2 files changed, 14 insertions, 5 deletions
diff --git a/meta-agl/recipes-core/systemd/systemd/wired.network b/meta-agl/recipes-core/systemd/systemd/wired.network
new file mode 100644
index 000000000..3559b0155
--- /dev/null
+++ b/meta-agl/recipes-core/systemd/systemd/wired.network
@@ -0,0 +1,5 @@
+[Match]
+Name=eth* en*
+
+[Network]
+DHCP=yes
diff --git a/meta-agl/recipes-core/systemd/systemd_%.bbappend b/meta-agl/recipes-core/systemd/systemd_%.bbappend
index 4e0d5d474..96ca6c69d 100644
--- a/meta-agl/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl/recipes-core/systemd/systemd_%.bbappend
@@ -1,13 +1,17 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += " file://e2fsck.conf "
+SRC_URI += "file://e2fsck.conf \
+ file://wired.network \
+ "
-# enable networkd support
-PACKAGECONFIG_append_pn-systemd = " networkd"
+# enable networkd/resolved support
+PACKAGECONFIG_append_pn-systemd = " networkd resolved"
do_install_append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
- install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
+ install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
+ # Install DHCP configuration for Ethernet adapters
+ install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
}
-FILES_${PN} += " /etc/e2fsck.conf "
+FILES_${PN} += "${sysconfdir}/e2fsck.conf "