summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework/recipes-devtools')
-rw-r--r--meta-app-framework/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb2
-rw-r--r--meta-app-framework/recipes-devtools/json-c/json-c_appfw.inc2
-rw-r--r--meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.bb4
-rw-r--r--meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.inc2
-rw-r--r--meta-app-framework/recipes-devtools/libappcontroller/libappcontroller_git.bb6
-rw-r--r--meta-app-framework/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host_appfw.inc2
-rw-r--r--meta-app-framework/recipes-devtools/run-postinsts/run-postinsts_appfw.inc8
7 files changed, 13 insertions, 13 deletions
diff --git a/meta-app-framework/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb b/meta-app-framework/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
index 3fea2ed91..4164171ff 100644
--- a/meta-app-framework/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
+++ b/meta-app-framework/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
inherit cmake
-FILES_${PN} += " ${datadir}/*/Modules/CMakeAfbTemplates*"
+FILES:${PN} += " ${datadir}/*/Modules/CMakeAfbTemplates*"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-app-framework/recipes-devtools/json-c/json-c_appfw.inc b/meta-app-framework/recipes-devtools/json-c/json-c_appfw.inc
index f1547e14b..c15548c55 100644
--- a/meta-app-framework/recipes-devtools/json-c/json-c_appfw.inc
+++ b/meta-app-framework/recipes-devtools/json-c/json-c_appfw.inc
@@ -1 +1 @@
-EXTRA_OECONF_append = " --enable-threading"
+EXTRA_OECONF:append = " --enable-threading"
diff --git a/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.bb b/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
index 1174ac4d7..9ca32fdda 100644
--- a/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
+++ b/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
@@ -2,7 +2,7 @@ require libafb-helpers_git.inc
inherit cmake
-RDEPENDS_${PN}_append = " af-binder"
+RDEPENDS:${PN}:append = " af-binder"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.inc b/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
index 739fee4a1..664f622a6 100644
--- a/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
+++ b/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
@@ -10,5 +10,5 @@ SRCREV = "16b77f6cea24332fffb75b6dcccb76f59565ed44"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
-DEPENDS_append = " af-binder jq"
+DEPENDS:append = " af-binder jq"
diff --git a/meta-app-framework/recipes-devtools/libappcontroller/libappcontroller_git.bb b/meta-app-framework/recipes-devtools/libappcontroller/libappcontroller_git.bb
index 0ee9c5e84..74fe08144 100644
--- a/meta-app-framework/recipes-devtools/libappcontroller/libappcontroller_git.bb
+++ b/meta-app-framework/recipes-devtools/libappcontroller/libappcontroller_git.bb
@@ -10,10 +10,10 @@ SRCREV = "1bef31c8bbad27f4914484c5007b2e199fb073d4"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
-DEPENDS_append = " af-binder libafb-helpers lua"
-RDEPENDS_${PN}_append = " af-binder lua"
+DEPENDS:append = " af-binder libafb-helpers lua"
+RDEPENDS:${PN}:append = " af-binder lua"
inherit cmake
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-app-framework/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host_appfw.inc b/meta-app-framework/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host_appfw.inc
index 8d6ffb5b3..27ee7cf52 100644
--- a/meta-app-framework/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host_appfw.inc
+++ b/meta-app-framework/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host_appfw.inc
@@ -1,4 +1,4 @@
-RDEPENDS_${PN}_append = " \
+RDEPENDS:${PN}:append = " \
nativesdk-af-main-tools \
nativesdk-af-binder-devtools \
nativesdk-cmake-apps-module \
diff --git a/meta-app-framework/recipes-devtools/run-postinsts/run-postinsts_appfw.inc b/meta-app-framework/recipes-devtools/run-postinsts/run-postinsts_appfw.inc
index 2f3effce6..07b958aea 100644
--- a/meta-app-framework/recipes-devtools/run-postinsts/run-postinsts_appfw.inc
+++ b/meta-app-framework/recipes-devtools/run-postinsts/run-postinsts_appfw.inc
@@ -1,14 +1,14 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/run-postinsts:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/run-postinsts:"
-SRC_URI_append = " file://ldconfig-wait.conf"
+SRC_URI:append = " file://ldconfig-wait.conf"
-do_configure_append() {
+do_configure:append() {
if ! grep -q StandardOutput= ${WORKDIR}/run-postinsts.service; then
sed -i '/ExecStart=/iStandardOutput=journal+console' ${WORKDIR}/run-postinsts.service
fi
}
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/systemd/system/run-postinsts.service.d
install -m 0644 ${WORKDIR}/ldconfig-wait.conf ${D}${sysconfdir}/systemd/system/run-postinsts.service.d
}