summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework/recipes-kernel')
-rw-r--r--meta-app-framework/recipes-kernel/linux/linux-%.bbappend1
-rw-r--r--meta-app-framework/recipes-kernel/linux/linux-appfw.inc23
-rw-r--r--meta-app-framework/recipes-kernel/linux/linux/audit.cfg2
-rw-r--r--meta-app-framework/recipes-kernel/linux/linux/smack-default-lsm-old.cfg2
-rw-r--r--meta-app-framework/recipes-kernel/linux/linux/smack-default-lsm.cfg2
-rw-r--r--meta-app-framework/recipes-kernel/linux/linux/smack.cfg9
6 files changed, 0 insertions, 39 deletions
diff --git a/meta-app-framework/recipes-kernel/linux/linux-%.bbappend b/meta-app-framework/recipes-kernel/linux/linux-%.bbappend
deleted file mode 100644
index 807da11f1..000000000
--- a/meta-app-framework/recipes-kernel/linux/linux-%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('APPFW_ENABLED', '1', 'linux-appfw.inc', '', d) if bb.data.inherits_class('kernel', d) else ''}
diff --git a/meta-app-framework/recipes-kernel/linux/linux-appfw.inc b/meta-app-framework/recipes-kernel/linux/linux-appfw.inc
deleted file mode 100644
index 68fb35882..000000000
--- a/meta-app-framework/recipes-kernel/linux/linux-appfw.inc
+++ /dev/null
@@ -1,23 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/linux:"
-
-# Enable SMACK support without making it the default explicitly.
-AGL_KCONFIG_FRAGMENTS += "smack.cfg"
-
-# Enable SMACK as default LSM, can be overridden by changing this
-# variable to e.g. "".
-#
-# NOTE:
-# We use a different fragment for kernels older than 5.x that predate
-# the switch to using CONFIG_LSM instead of CONFIG_DEFAULT_SECURITY.
-# For simplicity, logic to handle the change being made in 5.1 instead
-# of 5.0 has been omitted; in practice this should not be a problem
-# since no current BSPs have been seen that use 5.0.x. If a BSP
-# kernel recipe does not set LINUX_VERSION, the kernel being 5.x or
-# newer is assumed as the default behavior.
-LINUX_VERSION_MAJOR = "${@(d.getVar('LINUX_VERSION') or "5.x").split('.')[0]}"
-SMACK_DEFAULT_SUFFIX = "${@'' if int(d.getVar('LINUX_VERSION_MAJOR') or 0) >= 5 else '-old'}"
-SMACK_DEFAULT_SECURITY ??= "smack-default-lsm${SMACK_DEFAULT_SUFFIX}.cfg"
-AGL_KCONFIG_FRAGMENTS += "${SMACK_DEFAULT_SECURITY}"
-
-# Enable audit support
-AGL_KCONFIG_FRAGMENTS += "audit.cfg"
diff --git a/meta-app-framework/recipes-kernel/linux/linux/audit.cfg b/meta-app-framework/recipes-kernel/linux/linux/audit.cfg
deleted file mode 100644
index 214dbe33f..000000000
--- a/meta-app-framework/recipes-kernel/linux/linux/audit.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-CONFIG_AUDIT=y
-CONFIG_AUDITSYSCALL=y
diff --git a/meta-app-framework/recipes-kernel/linux/linux/smack-default-lsm-old.cfg b/meta-app-framework/recipes-kernel/linux/linux/smack-default-lsm-old.cfg
deleted file mode 100644
index b5c48454e..000000000
--- a/meta-app-framework/recipes-kernel/linux/linux/smack-default-lsm-old.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-CONFIG_DEFAULT_SECURITY="smack"
-CONFIG_DEFAULT_SECURITY_SMACK=y
diff --git a/meta-app-framework/recipes-kernel/linux/linux/smack-default-lsm.cfg b/meta-app-framework/recipes-kernel/linux/linux/smack-default-lsm.cfg
deleted file mode 100644
index 4791ebab3..000000000
--- a/meta-app-framework/recipes-kernel/linux/linux/smack-default-lsm.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-CONFIG_DEFAULT_SECURITY_SMACK=y
-CONFIG_LSM="lockdown,yama,loadpin,safesetid,integrity,smack,selinux,tomoyo,apparmor"
diff --git a/meta-app-framework/recipes-kernel/linux/linux/smack.cfg b/meta-app-framework/recipes-kernel/linux/linux/smack.cfg
deleted file mode 100644
index 45a92f148..000000000
--- a/meta-app-framework/recipes-kernel/linux/linux/smack.cfg
+++ /dev/null
@@ -1,9 +0,0 @@
-CONFIG_IP_NF_SECURITY=m
-CONFIG_IP6_NF_SECURITY=m
-CONFIG_EXT2_FS_SECURITY=y
-CONFIG_EXT3_FS_SECURITY=y
-CONFIG_EXT4_FS_SECURITY=y
-CONFIG_SECURITY=y
-CONFIG_SECURITY_SMACK=y
-CONFIG_SECURITY_SMACK_APPEND_SIGNALS=y
-CONFIG_TMPFS_XATTR=y