summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-common')
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb
new file mode 100644
index 000000000..eea9627b6
--- /dev/null
+++ b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Wayland IVI Extension"
+DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
+HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
+BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=176cedb32f48dd58f07e0c1c717b3ea4"
+
+DEPENDS = "weston"
+
+SRC_URI = "git://git.projects.genivi.org/${PN}.git \
+ "
+SRC_URI_append_wandboard = "file://wandboard_fix_build.patch"
+
+SRCREV = "44598504503eea5ac7f94c88477a5a78bda01f30"
+
+S = "${WORKDIR}/git"
+
+inherit cmake autotools
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[ivi-share] = "-DIVI_SHARE=ON,-DIVI_SHARE=OFF,libgbm libdrm"
+
+FILES_${PN} += "${libdir}/weston/*"
+FILES_${PN}-dbg += "${libdir}/weston/.debug/*"