summaryrefslogtreecommitdiffstats
path: root/meta-pipewire/recipes-multimedia/pipewire
diff options
context:
space:
mode:
Diffstat (limited to 'meta-pipewire/recipes-multimedia/pipewire')
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-alsa-plugin-allow-specifying-a-media.role-on-the-vir.patch124
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-null-sink-make-the-timerfd-non-blocking.patch43
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-systemd-Do-not-override-rootprefix.patch35
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire/0002-node-driver-make-the-timerfd-non-blocking.patch43
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire_1.0.0.bb (renamed from meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.30.bb)47
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire_1.0.0.bbappend (renamed from meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.30.bbappend)12
6 files changed, 72 insertions, 232 deletions
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-alsa-plugin-allow-specifying-a-media.role-on-the-vir.patch b/meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-alsa-plugin-allow-specifying-a-media.role-on-the-vir.patch
deleted file mode 100644
index c6cf373c2..000000000
--- a/meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-alsa-plugin-allow-specifying-a-media.role-on-the-vir.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-From ff019936a70262c176a4bd950bc80ab84d2a71b0 Mon Sep 17 00:00:00 2001
-From: George Kiagiadakis <george.kiagiadakis@collabora.com>
-Date: Tue, 22 Jun 2021 13:23:22 +0300
-Subject: [PATCH] alsa plugin: allow specifying a media.role on the virtual
- device name
-
-So that we can do:
- aplay -D pipewire:ROLE=Music music.wav
- aplay -D pipewire:ROLE=Notification notice.wav
-
-Upstream-Status: Backport [from master/0.3.31]
----
- pipewire-alsa/alsa-plugins/pcm_pipewire.c | 14 +++++++++++++-
- pipewire-alsa/conf/50-pipewire.conf | 11 ++++++++++-
- 2 files changed, 23 insertions(+), 2 deletions(-)
-
-diff --git a/pipewire-alsa/alsa-plugins/pcm_pipewire.c b/pipewire-alsa/alsa-plugins/pcm_pipewire.c
-index 86792d2c7..6ace1b689 100644
---- a/pipewire-alsa/alsa-plugins/pcm_pipewire.c
-+++ b/pipewire-alsa/alsa-plugins/pcm_pipewire.c
-@@ -59,6 +59,7 @@ typedef struct {
-
- char *node_name;
- char *target;
-+ char *role;
-
- int fd;
- int error;
-@@ -509,6 +510,9 @@ static int snd_pcm_pipewire_prepare(snd_pcm_ioplug_t *io)
- pw_properties_set(props, PW_KEY_MEDIA_CATEGORY,
- io->stream == SND_PCM_STREAM_PLAYBACK ?
- "Playback" : "Capture");
-+ if (pw->role != NULL &&
-+ pw_properties_get(props, PW_KEY_MEDIA_ROLE) == NULL)
-+ pw_properties_setf(props, PW_KEY_MEDIA_ROLE, "%s", pw->role);
-
- pw->stream = pw_stream_new(pw->core, pw->node_name, props);
- if (pw->stream == NULL)
-@@ -958,6 +962,7 @@ static int snd_pcm_pipewire_open(snd_pcm_t **pcmp, const char *name,
- const char *server_name,
- const char *playback_node,
- const char *capture_node,
-+ const char *role,
- snd_pcm_stream_t stream,
- int mode,
- uint32_t flags,
-@@ -1013,6 +1018,8 @@ static int snd_pcm_pipewire_open(snd_pcm_t **pcmp, const char *name,
- pw->target = capture_node ? strdup(capture_node) : NULL;
- }
-
-+ pw->role = (role && *role) ? strdup(role) : NULL;
-+
- pw->main_loop = pw_thread_loop_new("alsa-pipewire", NULL);
- if (pw->main_loop == NULL) {
- err = -errno;
-@@ -1091,6 +1098,7 @@ SND_PCM_PLUGIN_DEFINE_FUNC(pipewire)
- const char *server_name = NULL;
- const char *playback_node = NULL;
- const char *capture_node = NULL;
-+ const char *role = NULL;
- snd_pcm_format_t format = SND_PCM_FORMAT_UNKNOWN;
- int rate = 0;
- int channels = 0;
-@@ -1125,6 +1133,10 @@ SND_PCM_PLUGIN_DEFINE_FUNC(pipewire)
- snd_config_get_string(n, &capture_node);
- continue;
- }
-+ if (spa_streq(id, "role")) {
-+ snd_config_get_string(n, &role);
-+ continue;
-+ }
- if (spa_streq(id, "exclusive")) {
- if (snd_config_get_bool(n))
- flags |= PW_STREAM_FLAG_EXCLUSIVE;
-@@ -1174,7 +1186,7 @@ SND_PCM_PLUGIN_DEFINE_FUNC(pipewire)
- }
-
- err = snd_pcm_pipewire_open(pcmp, name, node_name, server_name, playback_node,
-- capture_node, stream, mode, flags, rate, format,
-+ capture_node, role, stream, mode, flags, rate, format,
- channels, period_bytes);
-
- return err;
-diff --git a/pipewire-alsa/conf/50-pipewire.conf b/pipewire-alsa/conf/50-pipewire.conf
-index 2c6f2d259..f7e58472b 100644
---- a/pipewire-alsa/conf/50-pipewire.conf
-+++ b/pipewire-alsa/conf/50-pipewire.conf
-@@ -3,9 +3,10 @@
- defaults.pipewire.server "pipewire-0"
- defaults.pipewire.node "-1"
- defaults.pipewire.exclusive false
-+defaults.pipewire.role ""
-
- pcm.pipewire {
-- @args [ SERVER NODE EXCLUSIVE ]
-+ @args [ SERVER NODE EXCLUSIVE ROLE ]
- @args.SERVER {
- type string
- default {
-@@ -27,6 +28,13 @@ pcm.pipewire {
- name defaults.pipewire.exclusive
- }
- }
-+ @args.ROLE {
-+ type string
-+ default {
-+ @func refer
-+ name defaults.pipewire.role
-+ }
-+ }
-
-
- type pipewire
-@@ -34,6 +42,7 @@ pcm.pipewire {
- playback_node $NODE
- capture_node $NODE
- exclusive $EXCLUSIVE
-+ role $ROLE
- hint {
- show on
- description "PipeWire Sound Server"
---
-2.30.2
-
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-null-sink-make-the-timerfd-non-blocking.patch b/meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-null-sink-make-the-timerfd-non-blocking.patch
deleted file mode 100644
index 71e526f86..000000000
--- a/meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-null-sink-make-the-timerfd-non-blocking.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From c633004bf310998580ff8944c59d94689d6fca87 Mon Sep 17 00:00:00 2001
-From: George Kiagiadakis <george.kiagiadakis@collabora.com>
-Date: Thu, 1 Jul 2021 11:37:01 +0300
-Subject: [PATCH] null-sink: make the timerfd non-blocking
-
-Fixes #1377
-
-Upstream-Status: Backport [from master/0.3.32]
-Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com>
----
- spa/plugins/support/null-audio-sink.c | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/spa/plugins/support/null-audio-sink.c b/spa/plugins/support/null-audio-sink.c
-index e9588f1e2..12e671db8 100644
---- a/spa/plugins/support/null-audio-sink.c
-+++ b/spa/plugins/support/null-audio-sink.c
-@@ -221,8 +221,11 @@ static void on_timeout(struct spa_source *source)
- spa_log_trace(this->log, "timeout");
-
- if (spa_system_timerfd_read(this->data_system,
-- this->timer_source.fd, &expirations) < 0)
-+ this->timer_source.fd, &expirations) < 0) {
-+ if (errno == EAGAIN)
-+ return;
- perror("read timerfd");
-+ }
-
- nsec = this->next_time;
-
-@@ -818,7 +821,8 @@ impl_init(const struct spa_handle_factory *factory,
-
- this->timer_source.func = on_timeout;
- this->timer_source.data = this;
-- this->timer_source.fd = spa_system_timerfd_create(this->data_system, CLOCK_MONOTONIC, SPA_FD_CLOEXEC);
-+ this->timer_source.fd = spa_system_timerfd_create(this->data_system, CLOCK_MONOTONIC,
-+ SPA_FD_CLOEXEC | SPA_FD_NONBLOCK);
- this->timer_source.mask = SPA_IO_IN;
- this->timer_source.rmask = 0;
- this->timerspec.it_value.tv_sec = 0;
---
-2.30.2
-
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-systemd-Do-not-override-rootprefix.patch b/meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-systemd-Do-not-override-rootprefix.patch
new file mode 100644
index 000000000..45d09e6b0
--- /dev/null
+++ b/meta-pipewire/recipes-multimedia/pipewire/pipewire/0001-systemd-Do-not-override-rootprefix.patch
@@ -0,0 +1,35 @@
+From 2501972518a67b1710998452d164cd077a4370f1 Mon Sep 17 00:00:00 2001
+From: Scott Murray <scott.murray@konsulko.com>
+Date: Thu, 17 Mar 2022 10:44:00 -0400
+Subject: [PATCH] systemd: Do not override rootprefix
+
+Do not override rootprefix with the value of prefix when querying
+systemdsystemunitdir from the systemd pkgconfig, as doing so forces
+the assumption that the system is running with usrmerge, which may
+not be the case. Instead, rely on the systemd.pc correctly
+representing the desired install locations.
+
+Reworked version of change in:
+
+https://git.automotivelinux.org/AGL/meta-agl/tree/meta-pipewire/recipes-multimedia/pipewire/pipewire/0012-Miscellanous-changes-to-account-for-lower-version-of.patch
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+---
+ src/daemon/systemd/system/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/daemon/systemd/system/meson.build b/src/daemon/systemd/system/meson.build
+index 84ca0b068..6956f2be3 100644
+--- a/src/daemon/systemd/system/meson.build
++++ b/src/daemon/systemd/system/meson.build
+@@ -1,4 +1,4 @@
+-systemd_system_services_dir = systemd.get_variable('systemdsystemunitdir', pkgconfig_define : [ 'rootprefix', prefix])
++systemd_system_services_dir = systemd.get_variable('systemdsystemunitdir')
+ if get_option('systemd-system-unit-dir') != ''
+ systemd_system_services_dir = get_option('systemd-system-unit-dir')
+ endif
+--
+2.35.1
+
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire/0002-node-driver-make-the-timerfd-non-blocking.patch b/meta-pipewire/recipes-multimedia/pipewire/pipewire/0002-node-driver-make-the-timerfd-non-blocking.patch
deleted file mode 100644
index 5a59d8676..000000000
--- a/meta-pipewire/recipes-multimedia/pipewire/pipewire/0002-node-driver-make-the-timerfd-non-blocking.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 5aa9c953909b936ba215ebca77461a17160f59fb Mon Sep 17 00:00:00 2001
-From: George Kiagiadakis <george.kiagiadakis@collabora.com>
-Date: Thu, 1 Jul 2021 11:50:40 +0300
-Subject: [PATCH] node-driver: make the timerfd non-blocking
-
-Relates to #1377
-
-Upstream-Status: Backport [from master/0.3.32]
-Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com>
----
- spa/plugins/support/node-driver.c | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/spa/plugins/support/node-driver.c b/spa/plugins/support/node-driver.c
-index 34533d0d9..32964110d 100644
---- a/spa/plugins/support/node-driver.c
-+++ b/spa/plugins/support/node-driver.c
-@@ -119,8 +119,11 @@ static void on_timeout(struct spa_source *source)
- spa_log_trace(this->log, "timeout");
-
- if (spa_system_timerfd_read(this->data_system,
-- this->timer_source.fd, &expirations) < 0)
-+ this->timer_source.fd, &expirations) < 0) {
-+ if (errno == EAGAIN)
-+ return;
- perror("read timerfd");
-+ }
-
- nsec = this->next_time;
-
-@@ -349,7 +352,8 @@ impl_init(const struct spa_handle_factory *factory,
-
- this->timer_source.func = on_timeout;
- this->timer_source.data = this;
-- this->timer_source.fd = spa_system_timerfd_create(this->data_system, CLOCK_MONOTONIC, SPA_FD_CLOEXEC);
-+ this->timer_source.fd = spa_system_timerfd_create(this->data_system, CLOCK_MONOTONIC,
-+ SPA_FD_CLOEXEC | SPA_FD_NONBLOCK);
- this->timer_source.mask = SPA_IO_IN;
- this->timer_source.rmask = 0;
- this->timerspec.it_value.tv_sec = 0;
---
-2.30.2
-
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.30.bb b/meta-pipewire/recipes-multimedia/pipewire/pipewire_1.0.0.bb
index 08f0eba35..6fa851caa 100644
--- a/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.30.bb
+++ b/meta-pipewire/recipes-multimedia/pipewire/pipewire_1.0.0.bb
@@ -20,7 +20,8 @@ SECTION = "multimedia"
DEPENDS = "dbus"
-SRCREV = "e857856be7b64d562cdcc01c43933218a68b225e"
+# v1.0.0(El Presidente)
+SRCREV = "4debdcd40b055b3eaa83a8f4443aa990ea566bfe"
SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https"
S = "${WORKDIR}/git"
@@ -52,6 +53,11 @@ USERADD_PARAM:${PN} = "--system --home / --no-create-home \
# instance does.
#
# manpage generation requires xmltoman, which is not available.
+#
+# Dont build any session managers along with pipewire
+# wireplumber is the session manger used in AGL and it will
+# be build in a different recipe
+#
EXTRA_OEMESON += " \
-Daudiotestsrc=enabled \
-Devl=disabled \
@@ -63,6 +69,7 @@ EXTRA_OEMESON += " \
-Dvulkan=disabled \
-Dlibcamera=disabled \
-Dman=disabled \
+ -Dsession-managers=[] \
"
PACKAGECONFIG ??= "\
@@ -77,7 +84,7 @@ PACKAGECONFIG ??= "\
# is why these two are marked in their respective packageconfigs
# as being in conflict.
-PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib udev"
+PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib udev,,pipewire-alsa-card-profile"
PACKAGECONFIG[bluez] = "-Dbluez5=enabled,-Dbluez5=disabled,bluez5 sbc"
PACKAGECONFIG[docs] = "-Ddocs=enabled,-Ddocs=disabled,doxygen-native"
PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base"
@@ -88,6 +95,7 @@ PACKAGECONFIG[systemd] = "-Dsystemd=enabled -Dsystemd-system-service=enabled ,-D
PACKAGECONFIG[v4l2] = "-Dv4l2=enabled,-Dv4l2=disabled,udev"
PACKAGECONFIG[pipewire-alsa] = "-Dpipewire-alsa=enabled,-Dpipewire-alsa=disabled,alsa-lib"
PACKAGECONFIG[pipewire-jack] = "-Dpipewire-jack=enabled -Dlibjack-path=${libdir}/${PW_MODULE_SUBDIR}/jack,-Dpipewire-jack=disabled,jack,,,jack"
+PACKAGECONFIG[pipewire-v4l2] = "-Dpipewire-v4l2=enabled -Dpipewire-v4l2=${libdir}/${PW_MODULE_SUBDIR}/v4l2,-Dpipewire-v4l2=disabled,v4l2"
PACKAGESPLITFUNCS:prepend = " split_dynamic_packages "
PACKAGESPLITFUNCS:append = " set_dynamic_metapkg_rdepends "
@@ -206,7 +214,7 @@ PACKAGES =+ "\
${PN}-pulse \
${PN}-alsa \
${PN}-jack \
- ${PN}-media-session \
+ ${PN}-v4l2 \
${PN}-spa-plugins \
${PN}-spa-plugins-meta \
${PN}-spa-tools \
@@ -222,9 +230,20 @@ SYSTEMD_SERVICE:${PN} = "pipewire.service"
CONFFILES:${PN} += "${datadir}/pipewire/pipewire.conf"
FILES:${PN} = " \
${datadir}/pipewire/pipewire.conf \
+ ${datadir}/pipewire/filter-chain.conf \
${datadir}/pipewire/filter-chain \
${systemd_user_unitdir}/pipewire.* \
+ ${systemd_system_unitdir}/pipewire* \
${bindir}/pipewire \
+ ${datadir}/pipewire/pipewire-avb.conf \
+ ${bindir}/pipewire-avb \
+ ${datadir}/pipewire/pipewire-aes67.conf \
+ ${bindir}/pipewire-aes67 \
+ ${datadir}/pipewire/pipewire.conf.avail \
+ ${datadir}/pipewire/pipewire-pulse.conf.avail \
+ ${datadir}/pipewire/client-rt.conf.avail \
+ ${datadir}/pipewire/client.conf.avail \
+ ${sysconfdir}/security/limits.d \
"
FILES:${PN}-dev += " \
@@ -234,6 +253,8 @@ FILES:${PN}-dev += " \
CONFFILES:libpipewire += "${datadir}/pipewire/client.conf"
FILES:libpipewire = " \
${datadir}/pipewire/client.conf \
+ ${datadir}/pipewire/client-rt.conf \
+ ${datadir}/pipewire/minimal.conf \
${libdir}/libpipewire-*.so.* \
"
# Add the bare minimum modules and plugins required to be able
@@ -268,25 +289,21 @@ FILES:${PN}-alsa = "\
${datadir}/alsa/alsa.conf.d/* \
"
+#lib to emulate v4l2 system calls on top of PipeWire
+FILES:${PN}-v4l2 = "\
+ ${libdir}/${PW_MODULE_SUBDIR}/v4l2/libpw-v4l2.so \
+"
+
# jack drop-in libraries to redirect audio to pipewire
CONFFILES:${PN}-jack = "${datadir}/pipewire/jack.conf"
FILES:${PN}-jack = "\
${datadir}/pipewire/jack.conf \
${libdir}/${PW_MODULE_SUBDIR}/jack/libjack*.so.* \
"
-
-# Example session manager. Not intended for use in production.
-CONFFILES:${PN}-media-session = "${datadir}/pipewire/media-session.d/*"
-SYSTEMD_SERVICE:${PN}-media-session = "pipewire-media-session.service"
-FILES:${PN}-media-session = " \
- ${bindir}/pipewire-media-session \
- ${datadir}/pipewire/media-session.d/* \
- ${systemd_system_unitdir}/pipewire-media-session.service \
-"
-RPROVIDES:${PN}-media-session = "virtual/pipewire-sessionmanager"
-
# Dynamic packages (see set_dynamic_metapkg_rdepends).
-FILES:${PN}-spa-plugins = ""
+FILES:${PN}-spa-plugins-bluez5 += " \
+ ${datadir}/${SPA_SUBDIR}/bluez5/bluez-hardware.conf \
+"
RRECOMMENDS:${PN}-spa-plugins += "${PN}-spa-plugins-meta"
FILES:${PN}-spa-tools = " \
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.30.bbappend b/meta-pipewire/recipes-multimedia/pipewire/pipewire_1.0.0.bbappend
index 53e4bb4b3..beb7c0817 100644
--- a/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.30.bbappend
+++ b/meta-pipewire/recipes-multimedia/pipewire/pipewire_1.0.0.bbappend
@@ -1,3 +1,7 @@
+SRC_URI += "\
+ file://0001-systemd-Do-not-override-rootprefix.patch \
+"
+
PACKAGECONFIG = "\
${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa pipewire-alsa', '', d)} \
@@ -6,17 +10,11 @@ PACKAGECONFIG = "\
gstreamer v4l2 \
"
-SRC_URI += "\
- file://0001-alsa-plugin-allow-specifying-a-media.role-on-the-vir.patch \
- file://0001-null-sink-make-the-timerfd-non-blocking.patch \
- file://0002-node-driver-make-the-timerfd-non-blocking.patch \
-"
-
do_install:append() {
# install symlinks to alsalib configuration files
for i in 50-pipewire.conf 99-pipewire-default.conf; do
if [ -f ${D}${datadir}/alsa/alsa.conf.d/${i} ]; then
- mkdir -p ${D}${sysconfdir}/alsa/conf.d
+ install -d ${D}${sysconfdir}/alsa/conf.d
ln -s ${datadir}/alsa/alsa.conf.d/${i} ${D}${sysconfdir}/alsa/conf.d/${i}
fi
done