aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-12-23 12:00:22 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:00:50 +0700
commitc7bf6dd5e219a9066f31debf177e23abe28f13a5 (patch)
tree7b44b0889e99cc46114acd0d63ce965116d8aa20 /meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch
parentca80cc5603eb810c8f47694f553b13ff79060ff1 (diff)
rcar-gen3: IPL: Update IPL version according to BSP v3.6.0
This commit changes following contents: - Update IPL and Secure Monitor Rev1.0.18 rev2 - Update optee_os Rev1.0.11 rev2 Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch')
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch b/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch
new file mode 100644
index 0000000..94d25ff
--- /dev/null
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch
@@ -0,0 +1,39 @@
+From 2035e9a30a235204b3d96ec369ad601dfd93579d Mon Sep 17 00:00:00 2001
+From: Jun Miyauchi <jun.miyauchi.sr@hitachi.com>
+Date: Fri, 22 Dec 2017 09:13:57 +0900
+Subject: [PATCH] Add LDFLAGS option
+
+---
+ libteec/Makefile | 2 +-
+ tee-supplicant/Makefile | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libteec/Makefile b/libteec/Makefile
+index 568a2cd..a9cca19 100644
+--- a/libteec/Makefile
++++ b/libteec/Makefile
+@@ -45,7 +45,7 @@ libteec: $(TEEC_LIBRARY)
+
+ $(TEEC_LIBRARY): $(TEEC_OBJS)
+ @echo " LINK $@"
+- $(VPREFIX)$(CC) -shared -Wl,-soname,$(LIB_MAJ_MIN) $(TEEC_LFLAGS) -o $@ $+
++ $(VPREFIX)$(CC) $(LDFLAGS) -shared -Wl,-soname,$(LIB_MAJ_MIN) $(TEEC_LFLAGS) -o $@ $+
+ @echo ""
+
+ $(TEEC_OBJ_DIR)/%.o: ${TEEC_SRC_DIR}/%.c
+diff --git a/tee-supplicant/Makefile b/tee-supplicant/Makefile
+index 737d39a..98e7408 100644
+--- a/tee-supplicant/Makefile
++++ b/tee-supplicant/Makefile
+@@ -69,7 +69,7 @@ tee-supplicant: $(TEES_FILE)
+
+ $(TEES_FILE): $(TEES_OBJS)
+ @echo " LINK $@"
+- $(VPREFIX)$(CC) -o $@ $+ $(TEES_LDFLAGS)
++ $(VPREFIX)$(CC) $(LDFLAGS) -o $@ $+ $(TEES_LDFLAGS)
+ @echo ""
+
+ $(TEES_OBJ_DIR)/%.o: $(TEES_SRC_DIR)/%.c
+--
+2.14.1.windows.1
+