aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp
diff options
context:
space:
mode:
authorDuy Dang <duy.dang.yw@rvc.renesas.com>2018-10-26 09:10:04 +0700
committerDuy Dang <duy.dang.yw@rvc.renesas.com>2018-10-26 09:45:21 +0700
commitc7688257d8a9428edc64ea00740c94e4f3efcbf7 (patch)
treec1a30039f43ff792a8f663d88aaa781e0337dfa8 /meta-rcar-gen3/recipes-bsp
parentd71480635ff07cfa48bbbd684c15a09fabb093b3 (diff)
rcar-gen3: OP-TEE: Apply fix patch for MMU configuration
This commit applies a patch to fix an issue in MMU configuration in which Linux or OP-TEE may overwrite to the illegal memory area. Signed-off-by: Duy Dang <duy.dang.yw@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp')
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch46
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb1
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch b/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch
new file mode 100644
index 0000000..f1d0739
--- /dev/null
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch
@@ -0,0 +1,46 @@
+From 67e2c72b2a20c859bc5cb7a2ea91b9bd9732c3a4 Mon Sep 17 00:00:00 2001
+From: Jun Miyauchi <jun.miyauchi.sr@hitachi.com>
+Date: Fri, 26 Oct 2018 10:39:08 +0900
+Subject: [PATCH] plat-rcar: fix MMU configuration of shared memory
+
+Signed-off-by: Jun Miyauchi <jun.miyauchi.sr@hitachi.com>
+---
+ core/arch/arm/plat-rcar/platform_config.h | 12 +++++-------
+ 1 file changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/core/arch/arm/plat-rcar/platform_config.h b/core/arch/arm/plat-rcar/platform_config.h
+index ebc12557..3c8fd8af 100644
+--- a/core/arch/arm/plat-rcar/platform_config.h
++++ b/core/arch/arm/plat-rcar/platform_config.h
+@@ -48,11 +48,11 @@
+ #define CFG_TA_RAM_SIZE (0x01E00000U) /* TA RAM size */
+
+ #define CFG_SHMEM_START (0x47E00000U) /* Share Memory address */
+-#define CFG_SHMEM_SIZE (0x00200000U) /* Share Memory size */
+- /* plus OP-TEE Log Area NS size(1MB) */
++#define CFG_SHMEM_SIZE (0x00100000U) /* Share Memory size */
+
+ #define OPTEE_LOG_BASE (0x46400000U) /* OP-TEE Log Area address */
+ #define OPTEE_LOG_NS_BASE (0x47FEC000U) /* OP-TEE Log Area NS address */
++#define OPTEE_LOG_NS_SIZE (0x00014000U) /* OP-TEE Log Area NS size */
+
+ #define TA_VERIFICATION_BASE (0x46200000U) /* TA area for verification */
+ #define TA_VERIFICATION_SIZE (0x00100000U) /* TA verification size */
+@@ -121,11 +121,9 @@
+ #define MEMORY1_EXEC false
+
+ /* LOG Area for Normal World */
+-/* Map with CFG_SHMEM_START
+-#define MEMORY2_BASE ROUNDDOWN(OPTEE_LOG_NS_BASE, MEM_SECTION_SIZE)
+-*/
+-#define MEMORY2_SIZE (MEM_SECTION_SIZE)
+-#define MEMORY2_TYPE MEM_AREA_IO_NSEC
++#define MEMORY2_BASE (OPTEE_LOG_NS_BASE)
++#define MEMORY2_SIZE (OPTEE_LOG_NS_SIZE)
++#define MEMORY2_TYPE MEM_AREA_RAM_NSEC
+ #define MEMORY2_SECURE false
+ #define MEMORY2_CACHED false
+ #define MEMORY2_DEVICE false
+--
+2.14.1
+
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 98c8776..f1e0e5b 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -27,6 +27,7 @@ SRC_URI_append = " \
file://0001-OPTEE_PROVIDER-188185-Fix-a-contxt-size-allocated-by.patch \
file://0002-OPTEE_PROVIDER-188122-Fix-to-exclusive-control-for-R.patch \
file://0001-Update-optee_os-Rev1.0.16-rev2.patch \
+ file://0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch \
"
COMPATIBLE_MACHINE = "(salvator-x|h3ulcb|m3ulcb|ebisu)"