aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-multimedia/webp
diff options
context:
space:
mode:
authorTakamitsu Honda <takamitsu.honda.pv@renesas.com>2017-01-27 11:47:06 +0900
committerTakamitsu Honda <takamitsu.honda.pv@renesas.com>2017-01-27 11:47:06 +0900
commit3613b2780a6b5d5d70ea6802be5060a8214cbdb5 (patch)
treefab60ccb7b38da7e8558a2879885f06e5b0662d2 /meta-rcar-gen3/recipes-multimedia/webp
Renesas BSP v3.5.1 (kernel v4.9 stable) [Environment] poky: yocto-2.1.2 (cca8dd15c8096626052f6d8d25ff1e9a606104a3) meta-openembedded: 55c8a76da5dc099a7bc3838495c672140cedb78e meta-linaro: 2f51d38048599d9878f149d6d15539fb97603f8f [Information] - U-boot: Changed load address from H'49000000 to H'50000000 - XDG_RUNTIME_DIR has been changed from "/run/user/root" to "/run/user/0" - Change location of include directory, which stores common user header files, to $(INCSHARED) - In BSP Only, core-image-weston is not supported even though local-wayland.conf is provided. - Please set Salvator-x SW7 Pin-1. In after Yocto BSP v2.12.0, it is  necessary to enable BKUP_TRG signal for Suspend to RAM. - The dtb filename was changed in R-Car H3. Only "Image-r8a7795-es1-salvator-x.dtb" is supported in this version. Please use "Image-r8a7795-es1-salvator-x.dtb" It supports R-Car H3 WS1.0 and WS1.1. - Please update your local.conf and bblayers.conf corresponding to Yocto v2.16.0 package. You can refer to meta-rcargen3/docs/sample/conf/ for updated contents. - You have to re-compile out-of-recipe software like user application by v2.16.0 SDK toolchains. - In some boards, the resuming from System Suspend to RAM may cause unstable operation or failed to resume. Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-multimedia/webp')
-rw-r--r--meta-rcar-gen3/recipes-multimedia/webp/libwebp/disabled_arm_neon.diff12
-rw-r--r--meta-rcar-gen3/recipes-multimedia/webp/libwebp_%.bbappend5
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/webp/libwebp/disabled_arm_neon.diff b/meta-rcar-gen3/recipes-multimedia/webp/libwebp/disabled_arm_neon.diff
new file mode 100644
index 0000000..80b1811
--- /dev/null
+++ b/meta-rcar-gen3/recipes-multimedia/webp/libwebp/disabled_arm_neon.diff
@@ -0,0 +1,12 @@
+diff --git a/src/dsp/dsp.h b/src/dsp/dsp.h
+index 95f1ce0..fc20ffe 100644
+--- a/src/dsp/dsp.h
++++ b/src/dsp/dsp.h
+@@ -73,7 +73,6 @@ extern "C" {
+ // inline assembly would need to be modified for use with Native Client.
+ #if (defined(__ARM_NEON__) || defined(WEBP_ANDROID_NEON) || \
+ defined(__aarch64__)) && !defined(__native_client__)
+-#define WEBP_USE_NEON
+ #endif
+
+ #if defined(_MSC_VER) && _MSC_VER >= 1700 && defined(_M_ARM)
diff --git a/meta-rcar-gen3/recipes-multimedia/webp/libwebp_%.bbappend b/meta-rcar-gen3/recipes-multimedia/webp/libwebp_%.bbappend
new file mode 100644
index 0000000..e9469ed
--- /dev/null
+++ b/meta-rcar-gen3/recipes-multimedia/webp/libwebp_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+# Add W/A patch for linaro gcc.
+# This patch disabled neon. (undefined #WEBP_USE_NEON)
+SRC_URI_append = " file://disabled_arm_neon.diff"