aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-08-09 23:31:18 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-09-11 17:29:11 +0000
commit20109e659434e77777ff6d39f9967d7831e1baca (patch)
tree91d770687518310dd286c6f569c6b951680f2002
parent5698cf23837e1730f21766bf1b34227b61d20133 (diff)
This upgrades the 'porter-nogfx' to pyro. The graphical target 'porter' still needs extra work. Change-Id: I5c193f74a779dcdce8dcfd0830344dfe6e72d515 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_%.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_%.bbappend b/meta-rcar-gen2/recipes-graphics/mesa/mesa_%.bbappend
new file mode 100644
index 0000000..af3a138
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa_%.bbappend
@@ -0,0 +1,17 @@
+require ../../include/gles-control.inc
+
+def map_libs(d):
+ if base_conditional('USE_GLES_WAYLAND', "1", "1", "0", d) == "1":
+ return "wayland"
+
+ if base_conditional('USE_GLES_X11', "1", "1", "0", d) == "1":
+ return "x11"
+
+ return "dummy"
+
+MESATARGET := "${@map_libs(d)}"
+include mesa-${MESATARGET}.inc
+
+# For R-Car E2 temporarily disable Cortex A7 optimisation to avoid upstream
+# build issue between YP 1.7 gcc toolchain and Mesa 10.1.x releases.
+#TARGET_CC_ARCH_remove_r8a7794 = "-mtune=cortex-a7"