aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
authorNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
committerNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
commit1c35920d85e424b3f65aa6df1dbde689dd6ec007 (patch)
tree58b2cacb3674111aad5a4ded694db0cef5cf55f3 /common/recipes-kernel
commit BSP v1.8.0
Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux-fusion/linux-fusion/linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch13
-rw-r--r--common/recipes-kernel/linux-fusion/linux-fusion_9.0.2.bb29
2 files changed, 42 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux-fusion/linux-fusion/linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch b/common/recipes-kernel/linux-fusion/linux-fusion/linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
new file mode 100644
index 0000000..22f8e25
--- /dev/null
+++ b/common/recipes-kernel/linux-fusion/linux-fusion/linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 0115a44..cb2856b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -25,7 +25,7 @@ ONE_CPPFLAGS += \
+ -I`pwd`/one/$(ONECORE) \
+ -I`pwd`/include \
+
+-KERNEL_BUILD = $(KERNELDIR)
++KERNEL_BUILD = $(KERNEL_SRC)
+ # works for 2.6.23
+ KERNEL_SOURCE = $(shell grep ^KERNELSRC $(KERNEL_BUILD)/Makefile | cut -d ' ' -f 6)
+ ifeq ($(KERNEL_SOURCE), )
diff --git a/common/recipes-kernel/linux-fusion/linux-fusion_9.0.2.bb b/common/recipes-kernel/linux-fusion/linux-fusion_9.0.2.bb
new file mode 100644
index 0000000..4a65c67
--- /dev/null
+++ b/common/recipes-kernel/linux-fusion/linux-fusion_9.0.2.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "The linux-fusion modules"
+LICENSE = "GPLv2"
+# dummy
+LIC_FILES_CHKSUM = "file://README;md5=54be18c46d265cc8ea0aafee3034a26d"
+
+DEPENDS = "virtual/kernel"
+
+inherit module
+
+PV = "9.0.2"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+SRCREV = "52f7ad63b4f98929fb15c2b73b9d40d39089f83e"
+SRC_URI = "git://git.directfb.org/git/directfb/core/linux-fusion.git;protocol=git \
+ file://linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"
+
+
+# inherit autotools pkgconfig
+
+export INSTALL_MOD_DIR="kernel/linux-fusion-modules"
+export KERNEL_SRC="${STAGING_KERNEL_DIR}"
+
+do_install_append() {
+ install -d ${D}/usr/include/linux
+ install -m 0644 ${S}/linux/include/linux/fusion.h ${D}/usr/include/linux
+}
+
+FILES_${PN}-headers = "/usr/include/linux"