aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorArthur Guyader <arthur.guyader@iot.bzh>2019-11-07 14:16:16 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2020-01-09 10:43:00 +0100
commit8b3af0fccba13e4098590322975bbd475d3d4f9e (patch)
tree29333136c9bca78a421697c048fd5379b062da88 /plugins/CMakeLists.txt
parent4e1db7198dc91adce159abbea60667400569d38c (diff)
controller: Prepare project ot use the Controller
Initialize an empty message_set to fill later when loading the Plugins Add the required method to be able to add a message_set Bug-AGL: SPEC-2988 Change-Id: I1dc784648f69832de8681184adaccbf5300f831d Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'plugins/CMakeLists.txt')
-rwxr-xr-xplugins/CMakeLists.txt69
1 files changed, 69 insertions, 0 deletions
diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
new file mode 100755
index 00000000..426689ef
--- /dev/null
+++ b/plugins/CMakeLists.txt
@@ -0,0 +1,69 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+#PROJECT_TARGET_ADD(agl-signals)
+
+# # Define targets
+# ADD_LIBRARY(${TARGET_NAME} MODULE ${TARGET_NAME}.cpp)
+
+# # Alsa Plugin properties
+# SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+# LABELS "PLUGIN"
+# PREFIX ""
+# SUFFIX ".ctlso"
+# OUTPUT_NAME ${TARGET_NAME}
+# )
+#
+# target_include_directories(${TARGET_NAME}
+# PRIVATE "../low-can-binding")
+
+# # Library dependencies (include updates automatically)
+# TARGET_LINK_LIBRARIES(${TARGET_NAME}
+# ini-config
+# openxc-message-format
+# uds-c
+# isotp-c
+# bitfield-c
+# afb-helpers
+# ${link_libraries})
+
+PROJECT_TARGET_ADD(agl-signals)
+
+ # Define targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE ${TARGET_NAME}.cpp)
+
+ # Alsa Plugin properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "PLUGIN"
+ PREFIX ""
+ SUFFIX ".ctlso"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ target_include_directories(${TARGET_NAME}
+ PRIVATE "../low-can-binding")
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ ini-config
+ openxc-message-format
+ uds-c
+ isotp-c
+ bitfield-c
+ afb-helpers
+ ${link_libraries})