aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederic Marec <frederic.marec@iot.bzh>2020-02-18 17:29:58 +0100
committerFrederic Marec <frederic.marec@iot.bzh>2020-02-20 15:16:45 +0100
commit57f46b7c5283b38f097aad630b39a65a203e992b (patch)
treee3ecb41e761844b43805f3b92e15e3d0bec52b73 /CMakeLists.txt
parent0957981a3b17a63ccdeb425d5b778af0faad7a47 (diff)
Update autobuild script to create multiple widget target debug, coverage and all Add config.cmake to match with cmake-app-module Adapt CMakeLists folowing those changes Bug-AGL: SPEC-2049 Signed-off-by: Frederic Marec <frederic.marec@iot.bzh> Change-Id: I2e1f520ff51b5174abb0f48d7a65352b8e58ce30
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 2 insertions, 20 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b758124..3fe99ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,24 +14,6 @@
# limitations under the License.
#
-project(SoundManager C CXX)
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
-cmake_minimum_required(VERSION 2.8)
-
-set(PROJECT_NAME "Sound Manager binding and client library")
-set(PROJECT_VERSION "1.0")
-set(PROJECT_PRETTY_NAME "SM")
-set(PROJECT_DESCRIPTION " Sound Manager binding and client library Binder communicates with Audio Manager and client library to hide IPC for Application")
-set(PROJECT_INCLUDEDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR})
-set(PROJECT_LIBDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
-set(PROJECT_BINDINGDIR ${binding_install_dir})
-set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
-
-# get pkgconfig
-INCLUDE(FindPkgConfig)
-link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
-
-set(CMAKE_BUILD_TYPE Debug)
-
-add_subdirectory(src)
-add_subdirectory(conf)
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)