aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 2 insertions, 20 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b758124..3fe99ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,24 +14,6 @@
# limitations under the License.
#
-project(SoundManager C CXX)
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
-cmake_minimum_required(VERSION 2.8)
-
-set(PROJECT_NAME "Sound Manager binding and client library")
-set(PROJECT_VERSION "1.0")
-set(PROJECT_PRETTY_NAME "SM")
-set(PROJECT_DESCRIPTION " Sound Manager binding and client library Binder communicates with Audio Manager and client library to hide IPC for Application")
-set(PROJECT_INCLUDEDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR})
-set(PROJECT_LIBDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
-set(PROJECT_BINDINGDIR ${binding_install_dir})
-set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
-
-# get pkgconfig
-INCLUDE(FindPkgConfig)
-link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
-
-set(CMAKE_BUILD_TYPE Debug)
-
-add_subdirectory(src)
-add_subdirectory(conf)
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)